TP-Link TL-WR940N(EU) v6.1 - is it supported?

waiting mode on for advance user to confirm that openwrt/lede working and succesed instaled on TP-Link TL-WR940N(EU) v6.1 :roll_eyes: :tired_face:

Hi, I have same problem as you. I have 10 pieces of wr940-v6.1 With many attempts I flash 6 of them, but now 2 days I trying flash next one. Without success :frowning:

Got it! Problem is that the eth port on notebook was not be able to switch on quickly enough and the router was not start downloading from tftp (on my laptop). The solution is to put a switch between them. Now 100% Success!


Right - 10 months after starting this thread, I can finally report success with this router. I'm afraid it took so long to revisit this project, as it initially absorbed so much of my time that I just couldn't find or justify any more time to spend on it back then. In case it helps others, here are the things which solved it for me:

  1. Getting this router into Failsafe mode can be a pain. The key is to press AND release the Reset button during the brief interval of time (2-3 seconds) when the light is flashing during the boot. The light flashing orange during the boot is the signal from the router that it will accept being placed into Failsafe mode. I was pressing and holding down the Reset button - which doesn't work. The sequence is:
    a. Turn on the router
    b. Blue light about 0.5 seconds
    c. Orange light steady about 8-12 secs
    d. pause 3 seconds
    e. orange flashing - about 3 seconds

When stage 'e' above is reached, with flashing orange light, after the led goes dark, press and release the Reset button, and the router enters Failsafe mode, and the light starts flashing orange quickly. This has worked for me every time during testing.

  1. The second biggest hurdle has been the TFTP server. I initially tried using the in.tftpd software which comes with Linux - which normally works for all sorts of other tasks. I've used it many times in the past. I checked it was listening on the right port and interface, I checked its log, I even had it running in the foreground - it never gave any sign that it has been contacted by the router. I never found out why. This has absorbed another large chunk of my troubleshooting time - as I assumed the router wasn't asking for any file - when in reality in.tftpd wasn't doing its job for some reason. As soon as I switched to using the tftp server built into dnsmasq - things worked straight away. I named the file "wr940nv6_tp_recovery.bin" as per @kretex comment above (thank you!) - and it worked out straight away. I have absolutely no idea why in.tftpd didn't even give a clue that it wasn't working.

So there it is. Finally this router is working. A whole bunch of time down the drain. Thank you very much to everybody who contributed above with suggestions - and I hope at least some of the info in this thread will be useful to some people out there.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.