TP-Link TL-WR740N v4.23 PPPoE not working, no internet connection

I'm new to OpenWRT, this is my first time using it. I installed version 17.01.07 on my old TP-Link TL-WR740N v4.23 router but I can't make internet working.
I have an ADSL modem connected to the router's WAN port and another cable from the router to the PC. I choose option PPPoE, put my ISP's login data, but the connection is not establishing. My PC get an IP address and I can ping my PC from the router and vice versa of course. I already read through the forum for solutions, I tried to play around with the configuration, but no change. I reset everything and tried again the PPPoE. That's the only thing I changed since the reset, so this is my /etc/config/network file now:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config globals 'globals'
        option ula_prefix 'fd7a:fa9b:267d::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username '**********'
        option ipv6 'auto'
        option password '*******'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0'

Could you help me?
My ISP is Telekom by the way.

Check the log for pppoe error messages. Often the ISP will reject your MAC address expecting the MAC of your old router. In that case you can clone it into the new router (option macaddr) or have the ISP reset the account.

These days it's also very common that the ISP expects VLAN tagging on WAN, check if that's the case for your contract.