TP-Link TL-WR1043ND v4.0 and latest LEDE problem (pado packets)

i'm using TL-WR1043ND v4.0 with LEDE (17.01.4) as gateway.
I've got disconnects very often - ethernet connection is going off although wifi connection remains ok.
Note i did tried placing different router, namely cisco linksys with openwrt - problem does not appear, and even same second model of WR1043 (lede aswell) - in this case there is the same problem.

So far, i've tried modyfing init.d script like mentioned here:
and modifying MTU for no avail.

Here is syslog:

If you need any more logs/configs, just ask. Please help

You might find some hints in this thread...

It appears that nothing at all is happening on the connection. This could be:

  • Router ppoe Ethernet port not connected to the modem.
  • A VLAN is required on the router to modem Ethernet, and is not set up.
  • Modem is not in bridge mode.
  • Modem not connected to the DSL line or problem at phone company end.
  • Previous connection not hung up (turn modem off for several minutes).

I recently started using this version and I experience the same drop if I do some type of upload, especially speedtest website. after the pppoe disconnect only a reboot will solve the problem, didn't encounter the problem on static(dhcp) wan connection
the v3 version is working flawlessly
there is a ticket about this too

just made a new build with
and some patches from nbd's staging related to ar and I could run multiple sessions of speed test without crash

it remains to be seen how stables is in time

Im not using any filters nor any telephones are plugged in.

Next time connection is down i will attach kernel log (read somewhere that such log was critical). Anyway could you help with troubleshooting please?

Here is my /etc/config/network:

The workaround script(s) jwoods provided is working nice - i no longer need to manually restart router, but issue still persists.

did you tried a build with the patches I pointed ?
I have 14:13:06 up 1 day, 15:20, load average: 0.16, 0.07, 0.01

pppoe-wan Link encap:Point-to-Point Protocol
          RX bytes:24655770902 (22.9 GiB)  TX bytes:13886783379 (12.9 GiB)
wlan0     Link encap:Ethernet  HWaddr 84:16:F9:66:xx:xx
          RX bytes:15524783783 (14.4 GiB)  TX bytes:9701443188 (9.0 GiB)


No, because frankly - I don't even have idea where to start

I uploaded an image TL-WR1043ND-v4 but it contains some packages that are not found in the standrad image, like acme,dnsmasq-full, mwan3, nano, mc, fwknopd, htop. curl, kmod-fast-classifier

so if you don't mind those, you can try it

If there will be no other option i will try Yours custom image (though i don't know exact source of problem and can't fix it - problem looks somewhat trivial for me).
On a sidenote, when disconnect happens there are no additional events logged to kernel log.
Someone else confirmed that this is working!

Installed and using this firmware. Will report stability after couple days.
Any ETA on 17.01.5?

edit 1 (day 1): packets sent=23568, received=23568, lost=0, latency min=0ms max=21ms avg=0ms
edit 2 (day 2): packets sent=15400, received=15398, lost=2, latency min=0ms max=20ms avg=0ms
Looks stable, good work! :slight_smile:
Thank You