TP-Link TL-WDR4900 v1 - OpenWrt 19.07.3 - Wifi Range/ performance issues

Hi,
I am using OpenWrt 19.07.3 on this router:
TP-Link TL-WDR4900 v1
https://openwrt.org/toh/tp-link/tl-wdr4900

For several years I have been running OpenWrt 14.07 (Barrier Breaker).

Since the upgrade to 19.07.3 I am facing issues with Wifi range and Wifi performance. With the old version 14.07 I was able to connect to the WLAN with my laptop from the kitchen to living room (2 walls ith doors but only 4-5 meters distance). Although the signal was a bit weak, it was working.

Now with 19.07.3 I even have complete connection drops.

I thought about just re-installing 14.07.
Or is there a way to install the old wireless driver from 14.07 in 19.07?
Are there console commands available to check which driver is loaded?
I am familiar to Linux. So i tried lsmod ..

Info:
It has 2 wireless cards:

Wireless1: Chip: AR9381-AL1A w/ 3x3 MIMO for 2.4GHz
Wireless2: Chip: AR9580-AR1A w/ 3x3 MIMO for 5Ghz

I am using the AR9381-AL1A 2.4 GHz.

Wifi driver used: ath9k

edit:
Or could I install larger antennas on this device? Does anyone have recommendations? The device was bought in 2014 and is discontinued by TP-Link as far as I know.

edit2:
Are there any useful tuning options like mentioned here? Just an example.
https://georgios-voulgarakis.info/index.php?option=com_content&view=article&id=10:improve-wifi-performance-on-lede&Itemid=101

Any help would be appreciated.

Many thanks in advance!
T.

New URL: https://openwrt.org/toh/tp-link/tl-wdr4900

The old page is for archival purposes only and does not receive updates any more.

OK, I have downgraded the firmware to:
OpenWrt 18.06.8

Wifi performance seems to be slightly better again now.

There are two 19.07 builds for that model. The old AR71xx and the new ath79 target. In general ath79 should be used. I have not noticed a difference in radio performance moving my ath9k hardware to ath79, but something may be squirrley in regards to rebooting after several hours of heavy wifi usage. It would be good to try them both and compare.

https://downloads.openwrt.org/releases/19.07.3/targets/ar71xx/generic/openwrt-19.07.3-ar71xx-generic-tl-wdr4900-v2-squashfs-sysupgrade.bin

https://downloads.openwrt.org/releases/19.07.3/targets/ath79/generic/openwrt-19.07.3-ath79-generic-tplink_tl-wdr4900-v2-squashfs-sysupgrade.bin

Note that when moving to ath79 the upgrade needs to be forced, and the option path of the wifi radios needs to be changed. Though 19.07.3 may be doing that automatically now.

1 Like

Damn it!

I am the hero of the day. But you @mk24 as well! Why?
Because I have the v1.3 version of the device but you provided links for the v2 hardware.

I realized that too late and now - know what? My device is BRICKED! :partying_face:

Means: unusable!
I tried the tftp recovery method without any success. No LEDs flashing any more. Only the indicator LED that an ethernet cable is plugged in.

Now I have 2 options. Buy a new router OR go the hard way and debrick via USB to serial console.

Luckily someone in my neighborhood sold me a cheap router as emergency backup so I can continue working from home tomorrow.

Lesson learned.

But you @mk24 could have also been realizing that I am using VERSION1 aka v1 (even stated in the title of my post).

Somehow I maybe also got tftpd not working correctly. Although it is an easy service to setup on Linux.. Mmh.

edit:
Does someone have a tip/ link what item to buy/ use or a howto for serial console debricking connection? Thanks.

https://openwrt.org/docs/techref/hardware/port.serial.cables#usb_pc_to_serial_router

1 Like

OK, I checked again and the router is definetely bricked. TFTP boot recovery is not possible. No power LED and no system LED any more on when going into recovery boot by holding reset button long and pressing power button.
Means: it is not responding to TFTP at all, also checked with tcpdump.

Regarding USB to serial @tmomas - does it matter which variant I use for this router (WDR4900) - TTL 5V or TTL 3.3V ?
Thanks.

OK. Meanwhile I have bought another router - a used Netgear R7800 which is running latest stable 19.07.3.

I find it a bit of a pity that @mk24 did not say a litte "sorry" yet. Of course, in the end it is my responsibility to not flash the wrong firmware. But he obviously did not read my posting in detail where I mentioned that I have the v1 Version of the WDR4900. And not v2, for what the links provided by him are intended for.

Nevermind.

I will try serial console debricking with an adapter. Found couple of good infos meanwhile.

Thread can be closed now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.