TP-Link TL-WDR4300 v1 : random reboots with OpenWrt (ath79) 19.07?

I'm getting random reboots (every few weeks) running OpenWRT (ath79) 19.07.3 on my TP-Link TL-WDR4300 v1 (Atheros AR9344).

This was not a problem with OpenWRT 18.06

I logged the serial port, but there is no clue there.

I don't think it's a hardware problem.

Is there a debug flags or debug kernel to run to try to isolate this ?

Thanks,
K

Are you running a mostly default configuration? Have you installed additional packages? Did you keep settings when you upgraded from 18.06 > 19.07, or did you re-create them manually? Is there a pattern to the reboots (i.e. time, heavy load, a specific feature/function being utilized, etc.)?

1 Like

One of my two devices had similar issues some time ago...
I switched the power units of them and then the other device was suffering from random reboots.
Can you test another power plug?

3 Likes

It's pretty plain. No additional packages. I recreated the settings manually when upgrading from 18.06 > 19.07. I haven't seen a pattern. The ISP is Comcast, so it's dual stack (ipv4 & ipv6).

I'll try that. I did have a power supply die on my parents TL-WR1043ND, so those power supplies don't last forever ...

What was the outcome for you?

I have same hardware, path, same isp, but reboots were daily at least, sometimes more. Main difference: I have a 3600 connecting as WDS client. It also was cross-graded to Ath79. 3600 is rock solid, even after swapping power supplies.

I just swapped the 4300 back to ar71xx, we shall see.

I still get reboots. Sometimes not for weeks or months, but coincidentally, I just got one.

I did do a few things to reduce the logread traffic : changed the WAN dropbear port from 22 to 2222. Also disabled root dropbear logins.

I have one 8" tablet that flaps it's wi-fi every few seconds, so I might try turning that off.

Port 22 open to the internet?!? Yikes .

FWIW, I'm at 3 days now on ar71xx, no restarts.