TP-Link TL-MR6400 v5 - can't get cellular working

I have got hold of one of these devices and successfully flashed the firmware and performed sysupgrade. I have installed the custom uqmi package from mrhaav. I have configured the interface in /etc/config/network like this:

config interface 'wwan'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option apn 'mob.asm.net'
        option pincode '0000'
        option auth 'none'
        option pdptype 'ipv4v6'
        option default_profile '1'
        option auto '0'

I have spent hours digging through the guides and forum topics, but I can't get much sense out of uqmi:

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
"Information unavailable"

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --start-network mob.asm.net --autoconnect
"No effect"

root@OpenWrt:~# uqmi -s -d /dev/cdc-wdm0 --get-current-settings
"Out of call"

Attempt at debugging:

root@OpenWrt:~# echo "05c6 9025 ff" > /sys/bus/usb-serial/drivers/option1/new_i
d

root@OpenWrt:~# picocom /dev/ttyUSB2
AT+CGDCONT?
+CGDCONT: 1,"IPV4V6","mob.asm.net","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

OK

It manages to retain the CGDCONT settings fine.

Can anyone help please?

Have you installed luci-proto-qmi?
What do you have in SYSLOG?

Try IPv4 only.

Yes, I have installed luci-proto-qmi.

The first time I send an uqmi command after startup, it hangs and I have to press CTRL+C; when I do this it prints "Failed to connect to service" and exits. The second time onwards it doesn't hang.

Excerpt from system log at startup:

Tue Oct 31 21:44:39 2023 user.info kernel: [   11.546707] kmodloader: loading kernel modules from /etc/modules.d/*
Tue Oct 31 21:44:39 2023 kern.info kernel: [   12.202905] usbcore: registered new interface driver cdc_wdm
Tue Oct 31 21:44:39 2023 kern.info kernel: [   12.211392] Loading modules backported from Linux version v6.1.24-0-g0102425ac76b
Tue Oct 31 21:44:39 2023 kern.info kernel: [   12.219016] Backport generated by backports.git v5.15.92-1-44-gd6ea70fafd36
Tue Oct 31 21:44:39 2023 kern.info kernel: [   12.302335] usbcore: registered new interface driver usbserial_generic
Tue Oct 31 21:44:39 2023 kern.info kernel: [   12.309143] usbserial: USB Serial support registered for generic
Tue Oct 31 21:44:39 2023 kern.info kernel: [   12.972649] mt76_wmac 10300000.wmac: ASIC revision: 76280001
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.031410] mt76_wmac 10300000.wmac: Firmware Version: 20151201
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.037453] mt76_wmac 10300000.wmac: Build Time: 20151201183641
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.079096] mt76_wmac 10300000.wmac: firmware init done
Tue Oct 31 21:44:39 2023 kern.debug kernel: [   14.250295] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.549745] PPP generic driver version 2.4.2
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.561214] NET: Registered PF_PPPOX protocol family
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.602605] qmi_wwan 1-1:1.4: cdc-wdm0: USB WDM device
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.627707] qmi_wwan 1-1:1.4 wwan0: register 'qmi_wwan' at usb-101c0000.ehci-1, WWAN/QMI device, 86:5b:92:6c:90:f9
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.638606] usbcore: registered new interface driver qmi_wwan
Tue Oct 31 21:44:39 2023 user.info kernel: [   14.648730] urngd: v1.0.2 started.
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.726365] usbcore: registered new interface driver option
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.732281] usbserial: USB Serial support registered for GSM modem (1-port)
Tue Oct 31 21:44:39 2023 kern.info kernel: [   14.796034] rt3050-esw 10110000.esw: port 0 link up
Tue Oct 31 21:44:39 2023 user.info kernel: [   14.890202] kmodloader: done loading kernel modules from /etc/modules.d/*

When I enable the USB serial interface, the following gets logged:

Wed Nov  1 08:24:03 2023 kern.info kernel: [ 4790.955972] option 1-1:1.0: GSM modem (1-port) converter detected
Wed Nov  1 08:24:03 2023 kern.info kernel: [ 4790.962598] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
Wed Nov  1 08:24:03 2023 kern.info kernel: [ 4790.970160] option 1-1:1.1: GSM modem (1-port) converter detected
Wed Nov  1 08:24:03 2023 kern.info kernel: [ 4790.976668] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
Wed Nov  1 08:24:03 2023 kern.info kernel: [ 4790.984217] option 1-1:1.2: GSM modem (1-port) converter detected
Wed Nov  1 08:24:03 2023 kern.info kernel: [ 4790.990783] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
Wed Nov  1 08:24:03 2023 kern.info kernel: [ 4790.998542] option 1-1:1.3: GSM modem (1-port) converter detected
Wed Nov  1 08:24:03 2023 kern.info kernel: [ 4791.005057] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB3

I've not set the interface to activate on startup. When I go into LuCI and restart the interface, I get:

Wed Nov  1 08:32:44 2023 daemon.notice netifd: Interface 'wwan' is setting up now
Wed Nov  1 08:32:54 2023 daemon.notice netifd: wwan (2563): PINcode disabled
Wed Nov  1 08:32:55 2023 daemon.notice netifd: wwan (2563): Data format set to raw-ip
Wed Nov  1 08:32:55 2023 daemon.notice netifd: wwan (2563): Default profile: 1
Wed Nov  1 08:32:55 2023 daemon.notice netifd: wwan (2563): Airplane mode off
Wed Nov  1 08:32:56 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:32:58 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:33:00 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:33:03 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:33:06 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:33:09 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:33:12 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:33:15 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:33:21 2023 daemon.notice netifd: wwan (2563):  searching on
Wed Nov  1 08:33:27 2023 daemon.notice netifd: wwan (2563):  searching on

When I change to ipv4 in LuCI and restart the interface, I get:

Wed Nov  1 08:34:43 2023 daemon.notice netifd: wwan (2970): PINcode disabled
Wed Nov  1 08:34:43 2023 daemon.notice netifd: wwan (2970): Data format set to raw-ip
Wed Nov  1 08:34:43 2023 daemon.notice netifd: wwan (2970): Default profile: 1
Wed Nov  1 08:34:43 2023 daemon.notice netifd: wwan (2970): Initiate airplane mode
Wed Nov  1 08:34:44 2023 daemon.notice netifd: wwan (2970): Change default profile
Wed Nov  1 08:34:44 2023 daemon.notice netifd: wwan (2970):  pdp-type: ipv4v6 to ipv4
Wed Nov  1 08:34:45 2023 daemon.notice netifd: wwan (2970): Airplane mode off
Wed Nov  1 08:34:46 2023 daemon.notice netifd: wwan (2970):  searching on
Wed Nov  1 08:34:48 2023 daemon.notice netifd: wwan (2970):  searching on
Wed Nov  1 08:34:50 2023 daemon.notice netifd: wwan (2970):  searching on

After switching to IPv4 only, the uqmi commands all produce the same output.

At some point yesterday evening I did manage to get the --get-signal-info command to output something that looked valid, but I can't remember how I did it!

Just to be clear I've now tried IPv4 only, but nothing has changed.

It looks like your LTE modem has problem to find any network.
Wed Nov 1 08:33:27 2023 daemon.notice netifd: wwan (2563): searching on

Have you the antennas connected? :wink:
Can you try to move the router to another place?

That was it! The logging wasn't very informative, but it turned out the problem was that I had no signal.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.