TP-Link TD-W9980B as router with cable modem


I hope someone can tell me how to move forward.
My goal is to use my newly aquired, openwrt-enabled, used TP-Link TD-W9980B as router before a cable modem as desribed here:

That is, as a first step I would like to keep the cable modem/router as it is (no bridge mode yet) and route all traffic from the LAN through the TP-Link to the cable modem into the internet and back (I worry about NAT problems later).

I have:
-A TP-Link TD-W9980B router with openwrt 18.06. I bought it used and preinstalled. I resetted it to default settings.
-My ISP is cable with a CBE CH6640E cable modem.

I configured the cable modem to use the 192.168.2.x address space. DHCP is still enabled, but should be disabled once everything is working. Also, WLAN is still enabled and will be disabled.
I configured the TP-Link to use the 192.168.1.x address space. DHCP is enabled.

My computers' Wifi is able to connect to the tp-link and is assigned a 192.168.1.x address. Also, I can access the web interface of openwrt by going to So I think this part works, which is I believe the part under Network->Interfaces->LAN. That part is also green.

To make the router connect to the internet, I think I have to connect to the cable modem through eth. This has to be configured in the WAN part of Network->Interfaces so that the router is both in 192.168.1.x and 192.168.2.x networks, correct?

I tried several options but none worked and I'm not sure what I need to configure.
The router has 4 eth ports at the back, the first 3 are labeleld LAN1, LAN2, LAN3, the 4th is labelled LAN4/WAN. I'm not sure if that means that I HAVE to use the 4th eth port to connect to the cable modem. The cable modem uses both ipv4 and ipv6, I'm not sure which is used when and why.

The current Network->Interfaces->LAN configuration is:
Protocol: Static address with
Interface: eth0.1, wlan0
The current Network->Interfaces->WAN configuration is:

Protocol: DHCP client
Interface: eth0

Switch settings:
CPU (eth0): 1000baseT, full duplex, tagged
LAN1: No link, untagged
LAN2: No link, untagged
LAN3: No link, untagged
LAN4: 1000baseT, full-duplex, untagged
I think I have to configure here to use the LAN4 port as exclusively going to the cable router, but I don't know what I have to do for that.

In the end, I would like to change the routers SSID to the one of my current WLAN, disable the cable modems wlan, disable the cable modems dhcp so that everything works as before :slight_smile:
Is that possible? Can anybody help me? I hope I supplied sufficient information.

I don't own a TD-W9980B but I believe it uses same Lantiq SoC as Home Hub 5a and so will have the same 'issues' known to the HH5A and other Lantiq modem routers.

Try going into Switch menu and check/define a second vlan, and assign your LAN4 port to it, to become new 'eth0.2' ethernet WAN port. Image below is for HH5A which has a dedicated WAN port.

See section 9.3 (and 9.2) of Installation Guide for HH5A which describes how to use the ethernet WAN port instead of DSL port for useful information.

ps. Don't expect more than 80-140 Mbps routed speeds.

1 Like

Thank you so much, that seems to work!
For reference, here is how it looks like on the TD-W9980B:

Thanks again!

(As a new user I can only put 1 image in a post)

Also for reference:
Next, I selected the new interface eth0.2 in WAN settings:

Please mark as 'Solved'.

Don't forget to disable 'DSL_control' to prevent random reboots.

Thanks, marked as solved.
I can't find an option DSL_control in the web interface, do I have to do that by editing a config file with ssh?

It can be done using LuCI.

refer to section 9.9 of installation guide for HH5A pdf. change from 'Enabled' to 'Disabled' and press 'Stop'

I don't know if random mac address on WAN interface affects TD-W9980. See section 7.9 of same guide.

1 Like

Thanks again, I found and changed the setting.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.