TP-Link repeaters cannot connect to repeat Wireless

Good afternoon from Spain.

A friend is using an TP-Link Archer C6 (US) with OpenWrt in last version (21.02) upgraded from a Snapshot when the TP-Link Archer C6 (EU), which I own, was in 19.07.

In the old OS version, he could connect perfectly 2 different TP-Link routers with the original OS to act as WiFi repeaters (not at the same time ofc but which he tested and changed in some case) of the router with OpenWrt.

However, since the upgrade to the 21.02 OS version, these routers cannot connect anymore at all. They seem to connect but keep a state of 'Without internet' and the OpenWrt router seems to not detect them as connected.

As a result, they cannot act as repeaters.

The case to put in context:

  • The TP-Link routers with the original OS can act as repeaters of other routers or themselves.
  • These routers acting as repeaters are a TP-Link Archer C58HP and a TP-Link TL-WR941HP.
  • Other common devices as some computers, smartphones and even chromecasts can connect to the OpenWrt router successfully and the OpenWrt router detect them as that.
  • We tried resetting the OpenWrt router configuration to default after upgrade too to know if had something to do with the issue since several parameters were changed (even if we did the migration steps through Luci we wanted to ensure that had nothing to do).
  • As the TP-Link routers with the original firmware are set with Uruguay region we also tried to change the wireless region in the OpenWrt router to Uruguay and rebooted after it to ensure.
  • I have already researched in this forum and other places but found unrelated issues and even tested their solutions to know if had some relationship or could work for the specific case (always reverting to state before in order to test the next proposal to make it clean).

After all of that, the TP-Link routers with the original firmware cannot repeat the signal.

We don't know if there was some important change which prevent the TP-Link routers to repeat signal with the new version.

I coursed System Administration including a subject dedicated to networks but there was nothing mentioned about a special negotiation to act as a repeater to other router: in summary, just connect to the AP, disable the DHCP server of the repeater and set a DHCP relay as we did in practices with Mikrotik or Cisco routers.

However, I read somewhere that WDS have different implementation of router manufacturers which could imply negotiation in the time to repeat but vaguely I found something about that.

I don't know if this thing apply here because in my own configuration at home (I have an OpenWrt router acting as repeater of a LibreCMC one) and before with my friend, the wireless AP was configured as that always and not as AP (WDS) suggested in some places.

I guess that the original firmware used WDS by default, or perhaps some proprietary protocol, to make this possible.

The case is that I don't understand how is that the post-19.07 snapshot allowed the other routers to act as repeaters correctly then.

There are some known issues with WDS links and 21.02.0 and 21.02.0_rc4. See the link below.

You could try 21.02.0_rc3 or the latest master snapshots. WDS worked well with rc3 and there should be fixes in the master now.


Thank you. We will wait to the next stable bugfix release update then.

I will upgrade this issue after testing it to know if was solved.