TP-Link RE650 OpenWrt installation

Moved it upstairs. Get no connection at all. Somehow it is not working without the network cable.

How do I fix this?

You would have a loop that would render the network unusable.
So better stick to one of the frequencies for backhauling to the ISP router and use the other as access point. If you are placing the repeater far from the ISP router prefer the 2,4GHz band, has better penetration through walls than 5GHz.

Install a wifi scanner on your phone. WiFiman, WiFiAnalyzer, or Net Analyzer some that I am using. Verify that there is adequate signal at the location of the RE650.

OK, I think I've figured most of it out.
Turns out that I've really had to create a bridge and keep only 1 master active, and not 2. When I had 2 i wasn't getting any connection. Now I only have 2.4 as the Master and the client, and both 5s are disabled. Now I am getting connection but it is very slow, 20 megabits at most but it fluctuates. With 5GHz only I was getting decent speeds but it wouldn't reach from the first floor to upstairs (it could with the original vendor firmware).
You said "So better stick to one of the frequencies for backhauling to the ISP router and use the other as access point". How do I do that?
Do I enable 5GHz as the client and keep the master disabled?

I moved the management ip to My home network is 192.168.0 /24. Finally figured out to set wwan as a staic IP outside of the DHCP scope and use the same one for the bridge After that
was able to connect to the management page while wireless. Finally!

Here is what I did. Please see if anything needs to be changed.

The section about accessing the OpenwRT device says that it is possible.
" With this setup your OpenWrt device itself may only be accessible from those computers directly connected to the W-LAN AP, not from the ones connected to the OpenWrt W-LAN client only, when in the subnet. It is however still possible to access the OpenWrt box via its address, when you are in that subnet. One way of being in both subnets at the same time with a Linux client is by adding a second, a virtual network interface to /etc/network/interfaces".

I honestly don't understand what he means by this. Moreover, there is no such thing as /etc/network/interfaces. But since I can now access it from the "extended" WIFI that is good enough for me.

So if you could help me out with the slow speed I'd really appreciate it. We are almost there.

The opposite, keep the 2,4GHz for client to the ISP router and use 2,4 and 5GHz as access point on the repeater.

Looks alright to me.

This guideline is for a linux wireless client. If your devices that connect on the repeater are windows you need to add a secondary IP on the wireless interface.

Did you do a site survey with the phone at the location of the RE650 as mentioned in the previous post?

Did what you suggested. 2.4 and 5 are both APs, and only 5 is the client.
AT first couldn't get anywhere but then it occured to me to check wwan interface. It switched to DHCP from static. Changed it back, rebooted, came back online. Wonder if it is a bug.
Now, at this moment my extender is less than 5 feet from the main router.
Per WiFiMan,
2.4 extended up/down: 3/5
5 extended: 100/20

Main network:
2.4: 90/20
5: 200/20

After doing these tests switched back to the extended wifi. Both have lost internet connection.
Rebooted the device. 5 is locked but has no Internet, 2.4 is off.
wwan interface is active and is set to a static IP.

I told you the opposite, use 2,4 for backhauling to the ISP router.

Apologies, it was a typo. 2.4 and 5 are APs, and 2.4 is the client.

Now all of a sudden LUCI decided to go down.
I can ssh to the IP but the web page does not come up.
Trying to fix this at the moment.

Restart the uhttpd
service uhttpd restart

service "uhttpd" not found....
hmmmm...did LUCI commit suicide? :slight_smile:

Tried OPKG update, not connecting....
Set the LAN IP back to 0.251 (just like I did in the beginning), the network config file has the DNS option pointing to Google (, rebooted. No go....

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option stp '1'
        option gateway ''
        option dns ''
        option dns ''

Anything wrong here?
I am about to reset it to the defaults and do it over again.
I've also reset the WIFI settings on the ISP router just in a case.

Nope, it looks correct to me.
Try also with /etc/init.d/uhttpd restart although I don't see the reason for service not to work.

Something must have gotten wiped out, resetting to the defaults and trying all over again.

Reset to the defaults, not able to download packages. I can ping the ip addresses but for some reason the hostname resolution is not working.

How would I fix this?

It just resolved by itself, very strange...Installing LUCI now.

New issue, cannot add an interface, as a matter of fact, any interface.
I press on "Add Interface", fill out the rest, click on Submit, and all I get is a spinning wheel. Rebooted the device and the laptop.

This thing with the spinning wheel has been reported by another snapshot user. Unfortunately the only thing you can do is to try another snapshot the next days.

Ah, OK, got it, a buggy build. Well, then, I am going to keep checking and see when the build is updated. Is it going to wipe out LUCI even if I preserve the settings?

It is rebuilt daily, just check on the site for the creation date and time.

The luci package, like all packages installed extra, will not be preserved. Only the configurations will be preserved.

There was a snapshot from today, had it flashed reset to the defaults. Same issue with the DNS resolution, ended up adding the ip for in the host file. After that was able to install LUCI...And couldn't add the interface. The bug hasn't been fixed.
Luckily, I still had a 3/28 file saved on my PC. Used that one.
First, no DNS resolution, worked like a charm (of course had to add the gateway and DNS but it is a given), and adding the interface is working. I wonder what broke between the 28th and now.
Hope it is going to be fixed eventually.
OK, going to set it all up now. WIll update.

Spent all evening, couldn't get it to work, nothing was connecting.
Decided to flash the original firmware, now it keeps blinking and I can't even reset to the defaults.
Did I brick it?