TP-Link RE650 OpenWrt installation

Hi, new OpenWRT user here.
Just installed the firmware on my RE650 extender.

Now what? From what I understand I have to install LUCI.
But I am not able to access the unit now. All light are OK, connected the LAN port with the link and the activity lights blinking but I can't get to SSH to the extender.
The LAN port's IP address is as assigned by DHCP.
Did I do anything wrong?
The firmware installation process was fine, I did not encounter any errors.

Your assumption is correct, you need to install luci, because you installed a snapshot version of OpenWrt, which doesn't include Luci. Unfortunately there is still no stable version of OpenWrt for your device, which includes Luci.
So in your case, you'll need to setup networking manually to have internet connectivity and install Luci.
What is the output of uci export network ?

Where/how would I type this command?

I want to emphasize that I am not able to get to the device through SSH for whatever reason.

By default OpenWrt images are using as routers ip address. Most probably you need to setup a static route to your router and go from there ...

I think it would be easier to setup the RE650 without connecting it on the upstream router for a start.
Your PC probably got dhcp settings from the upstream router because they are all connected.
So connect the PC to the RE650 and don't connect RE650 to the other router. Now if you renew the IP you'll get and you can SSH to the RE650.

Do you mean connect my PC to RE650 with the Ethernet cable?

I am going to do it in a few hours, gotta get some sleep now. Will report back.

Btw, my main reason for switching to openwrt is because I get disconnected from internet randomly, every so often. While the WiFi connection is up and systems I’ve remoted into remain connected I can’t browse websites or establish a new remote connection. Then I either have to wait until it gets resolved by itself or I have to disconnect and then reconnect the WiFi to instantly fix the problem. I am hoping openwrt can fix it for me. Especially now, in the work-from-home situation I’ve ended up in it becomes a real pain.

After spending many hours I was finally able to install LUCI. I couldn't install it normal way because it was failing due to some dependency. Eventually I've downloaded the same bin but with LUCI included from x-wrt. The default GUI was in Chinese. Luckily with Google Translate I was able to navigate the menus and set the language to English.
Now, I can't set up wifi properly. I want to create a new SSID that indicates
that it is an extended network and is separate from the main one. When I do it either the radio goes dead or I can't even join a newly created network. I don't understand what I am doing wrong. My main modem/router is on The OpenWRT device is on

Solution #1

x-wrt is not OpenWrt.
Download the daily snapshot from OpenWrt and install Luci immediately.
To be able to have both routers in the same broadcast domain, the preferred way is WDS if both devices support it. Otherwise the fallback is relayd.

How can I download the latest snapshot?
Also just realized something.
The static IP I've assigned could only be browsable if the lan port is plugged into my PC's ethernet or into the cable modem. I need to be able to connect to the management IP over wifi.
I've also tried assigning an IP which was on a different segment than my cable modem but then I wasn't able to access the web interface.
I am totally lost now, to be honest.
The original firmware took me less than 10 minutes to set up except it was never working right (constant disconnects). With this thing I've already spent nearly 20 hours, and I am nowhere to be close to my goal....

It is possible.

The device you are using is still not supported in a stable version, hence you have to use the snapshot and do some configuration manually in SSH to get initial connectivity. This is not easy, especially for a new user, but we'll help you as much as we can to overcome this.

Thank you, success, got openwrt installed with LUCI now running.

What is next?

My OpenWRT device is a wifi extender, the management IP should be browsable without using the ethernet port.
Also, the original firmware would allow me to browse the console through a mobile app. Is there something I could do with OpenWRT?

Well done!
If you want to use it as repeater, then the best option is WDS.
I hope that the other device supports it too.

Nope, just browser.

Please check out my screenshots.
Here is what I did:

  1. Scanned each one the Mediatek Radio buttons and connected to my main WiFi
  2. Under the device configuration I set up it as AP (WDS) and specified the SSID name based on the frequency.

Both WiFi links are up, both WiFi networks become available but I cannot connect to them.

The cable modem and the extender are on the same broadcast domain (the ips are and

Update: pays to RTFM, LOL

Forgot to change the network to LAN.

I am going through the rest of the manual, and it says to Go to Network , DHCP and DNS . Set DNS forwardings to the ip address of the AP router.
When I do that and enter it says that it is expecting a valid hostname.

Anyway, finally got my extended networks working but only through a wired connection which does not help.
Also, at this point it does not extend the network. Before flashing I was getting the full signal from the device, now I can't connect to it from my office upstairs as the signal is almost non existent. I am sure I am not doing something correctly....

From what I read on Google: At it's core, this device is superb - more or less the best in class regarding throughput and range, at least when it comes to repeaters with a built-in power plug. I would stick with the original firmware as there no way in hell Openwrt is coming near that performance.

1 Like

Is there any way I could go back?
The reason I've decided to switch was because my device could not keep the Internet connection up and would require to switch back and forth between the wifi networks all the time.

Still struggling.
Here is what I did.
Scanned the network, added wifi, set as client.
Then went to the same radio, added a new network, auto named OpenWrt, mode: Master, Access Point, network vlan.
Problem: I get the connection up for the 2.4 network almost right away but not for 5. I've gotten it once but decided to rename it and after that couldn't get it to work. Tried rebooting, deleting the networks, cleaned up the wireless file in /etc/config/wireless to make sure i wasn't leaving anything out that shouldn't be there anymore. Nothing, 5GHz does not light up at all.
2.4's speed has barely reached 2 megabits, so it is unusable.
What do I do next?

Due to STP you cannot have both 2,4 and 5GHz backhauling to the ISP router.
One of them will be acting as WDS client.
Other than the low speed is it working fine as a repeater?
Do you want to troubleshoot further?

I am going to try moving the unit one floor up and see if I can get the signal on the second floor where i am needed it most.

What if I disable STP? After all, my network is fairly simple, the ISP router and the OpenWRT extender.