TP-link RE650 bricked after firmware update


I come to seek some help.

My TP-Link RE650 is bricked, since I tried to do firmware update from OpenWRT snapshot to OpenWRT 21.02.1.

Now device is stuck on bootloader...
Accessing serial shows this:
Please choose the operation:
1: Load system code to SDRAM via TFTP.
2: Load system code then write to Flash via TFTP.
3: Boot system code via Flash (default).
4: Entr boot command line interface.
7: Load Boot Loader code then write to Flash via Serial.
9: Load Boot Loader code then write to Flash via TFTP. 0

3: System Boot system code via Flash.

Booting image at bfc20000 ...

text base: ffffffff
entry point: ffffffff
Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover

I already tried option 2 to install stock firmware and Openwrt firmware but still, device is showing the same issue.

Is there still any hope for this repeater or is it good to go to trash ?

This thread may be helpful...

Thank you for your answer.

Following another thread, I flashed another uboot.
Now I don't have any output from serial.

I think it is gone for good now. :sweat_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.