[SOLVED] TP-Link RE450 V2 AP configuration wifi0 5GHz Wireless is not associated

I'm trying to configure my RE450 as AP for both wifi radios.
Firmware is current openwrt-19.07.7-ath79-generic-tplink_re450-v2-squashfs-sysupgrade.bin

radio0 shows "Wireless is not associated", radio1 is working flawlessly though.
I have read some got it working by choosing the right channel, but thad did not do the trick. I don't see the AP on my mobile, the LED for 5GHz stays dark also.

How can I be sure that the hardware is ok and how to configure it correctly?

root@OpenWrt:/# cat etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option country 'DE'
        option htmode 'VHT40'
        option channel '120'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Openwrt5'
        option key 'abc'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211w '2'
        option encryption 'psk2'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option country 'DE'
        option channel '13'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'Openwrt'
        option wpa_disable_eapol_key_retries '1'
        option ieee80211w '1'
        option key 'abc'
        option encryption 'psk2'
        option network 'lan'

root@OpenWrt:/# cat etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf9:32a7:66b6::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.178.3'
        option gateway '192.168.178.1'
        list dns '192.168.178.101'
        list dns '8.8.8.8'

config interface 'relayd'
        option proto 'relay'

The system log does not look very good:

Fri Apr 16 10:17:39 2021 kern.info kernel: [    9.705643] ath10k 4.19 driver, optimized for CT firmware, probing pci device: 0x3c.
Fri Apr 16 10:17:39 2021 user.info kernel: [    9.716668] urngd: v1.0.2 started.
Fri Apr 16 10:17:39 2021 kern.warn kernel: [    9.723747] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
Fri Apr 16 10:17:39 2021 kern.info kernel: [    9.729768] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
Fri Apr 16 10:17:39 2021 kern.notice kernel: [    9.899285] random: crng init done
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   10.043132] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:00:00.0.txt failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   10.054038] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   10.441051] firmware ath10k!fwcfg-pci-0000:00:00.0.txt: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   10.450431] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   10.461514] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   10.891134] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   10.901859] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-5.bin failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   10.913222] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   11.272140] firmware ath10k!QCA988X!hw2.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   11.281965] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-2.bin failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   11.293326] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   11.549292] firmware ath10k!QCA988X!hw2.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   11.559148] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   11.570235] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   11.748305] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   11.757862] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   11.768949] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   11.969352] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   11.978913] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-4.bin failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   11.989999] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   12.168731] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   12.178288] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   12.189392] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   12.378853] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.info kernel: [   12.582361] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
Fri Apr 16 10:17:39 2021 kern.info kernel: [   12.591937] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
Fri Apr 16 10:17:39 2021 kern.info kernel: [   12.604423] ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-8x-__fW-022-538f0906 api 2 features wmi-10.x,has-wmi-mgmt-tx,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT crc32 e1c91a74
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   12.657804] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   12.668613] ath10k_pci 0000:00:00.0: Falling back to user helper
Fri Apr 16 10:17:39 2021 kern.err kernel: [   12.762384] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
Fri Apr 16 10:17:39 2021 kern.info kernel: [   12.771858] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
Fri Apr 16 10:17:39 2021 kern.warn kernel: [   13.720073] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Fri Apr 16 10:17:39 2021 kern.info kernel: [   13.736993] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Fri Apr 16 10:17:39 2021 kern.info kernel: [   13.743275] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Fri Apr 16 10:17:39 2021 kern.info kernel: [   13.751543] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20984 iram: 25656'
Fri Apr 16 10:17:39 2021 kern.info kernel: [   13.801214] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 2 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1
Fri Apr 16 10:17:39 2021 kern.info kernel: [   13.814293] ath10k_pci 0000:00:00.0: NOTE:  Firmware DBGLOG output disabled in debug_mask: 0x10000000
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   13.954281] ath: EEPROM regdomain: 0x0
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   13.954287] ath: EEPROM indicates default country code should be used
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   13.954290] ath: doing EEPROM country->regdmn map search
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   13.954302] ath: country maps to regdmn code: 0x3a
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   13.954307] ath: Country alpha2 being used: US
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   13.954310] ath: Regpair used: 0x3a
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   14.028675] ath: EEPROM regdomain: 0x0
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   14.028684] ath: EEPROM indicates default country code should be used
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   14.028687] ath: doing EEPROM country->regdmn map search
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   14.028700] ath: country maps to regdmn code: 0x3a
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   14.028705] ath: Country alpha2 being used: US
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   14.028708] ath: Regpair used: 0x3a
Fri Apr 16 10:17:39 2021 kern.debug kernel: [   14.041131] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Fri Apr 16 10:17:39 2021 kern.info kernel: [   14.042697] ieee80211 phy1: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
Fri Apr 16 10:17:39 2021 user.info kernel: [   14.125615] kmodloader: done loading kernel modules from /etc/modules.d/*
Fri Apr 16 10:17:41 2021 authpriv.info dropbear[1030]: Not backgrounding
Fri Apr 16 10:17:42 2021 user.notice : Added device handler type: 8021ad
Fri Apr 16 10:17:42 2021 user.notice : Added device handler type: 8021q
Fri Apr 16 10:17:42 2021 user.notice : Added device handler type: macvlan
Fri Apr 16 10:17:42 2021 user.notice : Added device handler type: veth
Fri Apr 16 10:17:42 2021 user.notice : Added device handler type: bridge
Fri Apr 16 10:17:42 2021 user.notice : Added device handler type: Network device
Fri Apr 16 10:17:42 2021 user.notice : Added device handler type: tunnel
Fri Apr 16 10:17:45 2021 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/dhcp
Fri Apr 16 10:17:45 2021 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/radvd
Fri Apr 16 10:17:45 2021 user.notice ucitrack: Setting up /etc/config/wireless reload dependency on /etc/config/network
Fri Apr 16 10:17:46 2021 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/luci-splash
Fri Apr 16 10:17:46 2021 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/qos
Fri Apr 16 10:17:46 2021 user.notice ucitrack: Setting up /etc/config/firewall reload dependency on /etc/config/miniupnpd
Fri Apr 16 10:17:46 2021 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/odhcpd
Fri Apr 16 10:17:46 2021 user.notice ucitrack: Setting up non-init /etc/config/fstab reload handler: /sbin/block mount
Fri Apr 16 10:17:46 2021 user.notice ucitrack: Setting up /etc/config/system reload trigger for non-procd /etc/init.d/led
Fri Apr 16 10:17:47 2021 kern.info kernel: [   22.968193] br-lan: port 1(eth0) entered blocking state
Fri Apr 16 10:17:47 2021 kern.info kernel: [   22.973644] br-lan: port 1(eth0) entered disabled state
Fri Apr 16 10:17:47 2021 kern.info kernel: [   22.979292] device eth0 entered promiscuous mode
Fri Apr 16 10:17:47 2021 kern.info kernel: [   23.015143] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
Fri Apr 16 10:17:47 2021 daemon.notice netifd: Interface 'lan' is enabled
Fri Apr 16 10:17:47 2021 daemon.notice netifd: Interface 'lan' is setting up now
Fri Apr 16 10:17:47 2021 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/luci_statistics
Fri Apr 16 10:17:47 2021 daemon.notice netifd: Interface 'lan' is now up
Fri Apr 16 10:17:47 2021 daemon.notice netifd: Interface 'loopback' is enabled
Fri Apr 16 10:17:47 2021 daemon.notice netifd: Interface 'loopback' is setting up now
Fri Apr 16 10:17:47 2021 daemon.notice netifd: Interface 'loopback' is now up
Fri Apr 16 10:17:47 2021 daemon.notice netifd: Network device 'lo' link is up
Fri Apr 16 10:17:47 2021 daemon.notice netifd: Interface 'loopback' has link connectivity
Fri Apr 16 10:17:47 2021 user.notice ucitrack: Setting up /etc/config/system reload dependency on /etc/config/dhcp
Fri Apr 16 10:17:47 2021 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436650] ath: EEPROM regdomain: 0x8114
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436658] ath: EEPROM indicates we should expect a country code
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436661] ath: doing EEPROM country->regdmn map search
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436666] ath: country maps to regdmn code: 0x37
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436671] ath: Country alpha2 being used: DE
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436674] ath: Regpair used: 0x37
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436680] ath: regdomain 0x8114 dynamically updated by user
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436753] ath: EEPROM regdomain: 0x8114
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436756] ath: EEPROM indicates we should expect a country code
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436759] ath: doing EEPROM country->regdmn map search
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436762] ath: country maps to regdmn code: 0x37
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436766] ath: Country alpha2 being used: DE
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436769] ath: Regpair used: 0x37
Fri Apr 16 10:17:48 2021 kern.debug kernel: [   24.436772] ath: regdomain 0x8114 dynamically updated by user
Fri Apr 16 10:17:48 2021 daemon.notice procd: /etc/rc.d/S96led: setting up led LAN Data
Fri Apr 16 10:17:48 2021 daemon.notice procd: /etc/rc.d/S96led: setting up led LAN Link
Fri Apr 16 10:17:50 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Fri Apr 16 10:17:50 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Fri Apr 16 10:17:50 2021 daemon.err hostapd: nl80211 driver initialization failed.
Fri Apr 16 10:17:50 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Fri Apr 16 10:17:50 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Fri Apr 16 10:17:50 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Fri Apr 16 10:17:50 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Fri Apr 16 10:17:50 2021 daemon.notice netifd: radio0 (1297): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Fri Apr 16 10:17:50 2021 daemon.notice netifd: radio0 (1297): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process  path (/proc/exe)
Fri Apr 16 10:17:50 2021 daemon.notice netifd: radio0 (1297): Command failed: Invalid argument
Fri Apr 16 10:17:50 2021 daemon.notice netifd: radio0 (1297): Device setup failed: HOSTAPD_START_FAILED
Fri Apr 16 10:17:50 2021 daemon.info procd: - init complete -

Thx in advance for any help :slight_smile:

Edit: This guy here had apperantly a similar problem, but no solution: Unable to start 5 GHz Master network on RE450

hostapd crashes immediately likely because it can't parse config. Remove the 80211w config. I think that a different wpad is required for support of 11w. Start by trying a very simple WPA2 PSK AP with no special options.

Also since you've chosen a DFS channel it will have to listen for radar for 60 seconds before the AP finally goes on the air. The log will show "DFS-CAC-START" for this process (It isn't getting that far yet).

Thank you for the reply.
I changed to standard configuration and still no LED or AP availiable :frowning:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option country 'DE'
        option htmode 'VHT40'
        option channel 'auto'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Openwrt5'
        option key 'abc'
        option encryption 'psk2'
        option network 'lan'

system log:

Fri Apr 16 17:00:32 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Fri Apr 16 17:00:32 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Fri Apr 16 17:00:32 2021 daemon.err hostapd: nl80211 driver initialization failed.
Fri Apr 16 17:00:32 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Fri Apr 16 17:00:32 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Fri Apr 16 17:00:32 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Fri Apr 16 17:00:32 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Fri Apr 16 17:00:32 2021 daemon.notice netifd: radio0 (3486): cat: can't open '/var/run/wifi-phy0.pid': No such file or directory
Fri Apr 16 17:00:32 2021 daemon.notice netifd: radio0 (3486): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process  path (/proc/exe)
Fri Apr 16 17:00:32 2021 daemon.notice netifd: radio0 (3486): Command failed: Invalid argument
Fri Apr 16 17:00:32 2021 daemon.notice netifd: radio0 (3486): Device setup failed: HOSTAPD_START_FAILED

I would be more than happy to provide more information or logs to solve this topic, but don't know what exactly could be helpful. Please feel free to ask.

I found a solution here:

Basic solution is to add the mac address of the device to 3 different places. This seems to work for me.
Thanks again for the forum and help, I will mark this as solved. I'm happy XD

system log:

Fri Apr 16 19:17:46 2021 daemon.notice hostapd: wlan0: ACS-COMPLETED freq=5785 channel=157
Fri Apr 16 19:17:46 2021 daemon.notice hostapd: wlan0: interface state ACS->HT_SCAN
Fri Apr 16 19:17:46 2021 daemon.err hostapd: Using interface wlan0 with hwaddr e4:c3:2a:89:6f:c6 and ssid "Openwrt5"
Fri Apr 16 19:17:46 2021 kern.info kernel: [  527.989532] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Fri Apr 16 19:17:46 2021 kern.info kernel: [  527.996379] br-lan: port 2(wlan0) entered blocking state
Fri Apr 16 19:17:46 2021 kern.info kernel: [  528.001941] br-lan: port 2(wlan0) entered forwarding state
Fri Apr 16 19:17:46 2021 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Fri Apr 16 19:17:46 2021 daemon.notice hostapd: wlan0: AP-ENABLED
Fri Apr 16 19:17:56 2021 daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
Fri Apr 16 19:17:56 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Fri Apr 16 19:17:56 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Fri Apr 16 19:17:56 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Fri Apr 16 19:17:56 2021 kern.info kernel: [  538.119086] device wlan0 left promiscuous mode
Fri Apr 16 19:17:56 2021 kern.info kernel: [  538.123893] br-lan: port 2(wlan0) entered disabled state
Fri Apr 16 19:17:57 2021 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Fri Apr 16 19:17:58 2021 kern.warn kernel: [  540.475850] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Fri Apr 16 19:17:58 2021 kern.info kernel: [  540.493068] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Fri Apr 16 19:17:58 2021 kern.info kernel: [  540.499335] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Fri Apr 16 19:17:58 2021 kern.info kernel: [  540.509039] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20984 iram: 25656'
Fri Apr 16 19:17:59 2021 kern.warn kernel: [  540.576983] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Fri Apr 16 19:17:59 2021 kern.info kernel: [  540.596491] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Fri Apr 16 19:17:59 2021 kern.info kernel: [  540.612154] br-lan: port 2(wlan0) entered blocking state
Fri Apr 16 19:17:59 2021 kern.info kernel: [  540.617678] br-lan: port 2(wlan0) entered disabled state
Fri Apr 16 19:17:59 2021 kern.info kernel: [  540.623471] device wlan0 entered promiscuous mode
Fri Apr 16 19:17:59 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Fri Apr 16 19:17:59 2021 daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
Fri Apr 16 19:17:59 2021 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->ACS
Fri Apr 16 19:17:59 2021 daemon.notice hostapd: wlan0: ACS-STARTED
Fri Apr 16 19:18:13 2021 daemon.notice hostapd: wlan0: ACS-COMPLETED freq=5785 channel=157
Fri Apr 16 19:18:13 2021 daemon.notice hostapd: wlan0: interface state ACS->HT_SCAN
Fri Apr 16 19:18:13 2021 daemon.err hostapd: Using interface wlan0 with hwaddr e4:c3:2a:89:6f:c6 and ssid "Openwrt5"
Fri Apr 16 19:18:13 2021 kern.info kernel: [  555.106529] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Fri Apr 16 19:18:13 2021 kern.info kernel: [  555.113276] br-lan: port 2(wlan0) entered blocking state
Fri Apr 16 19:18:13 2021 kern.info kernel: [  555.118768] br-lan: port 2(wlan0) entered forwarding state
Fri Apr 16 19:18:13 2021 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Fri Apr 16 19:18:13 2021 daemon.notice hostapd: wlan0: AP-ENABLED
Fri Apr 16 19:18:13 2021 daemon.notice netifd: Network device 'wlan0' link is up
Fri Apr 16 19:18:57 2021 daemon.info hostapd: wlan0: STA e0:dc:ff:ed:f3:a1 IEEE 802.11: authenticated
Fri Apr 16 19:18:57 2021 daemon.info hostapd: wlan0: STA e0:dc:ff:ed:f3:a1 IEEE 802.11: associated (aid 1)
Fri Apr 16 19:18:57 2021 daemon.notice hostapd: wlan0: AP-STA-CONNECTED e0:dc:ff:ed:f3:a1
Fri Apr 16 19:18:57 2021 daemon.info hostapd: wlan0: STA e0:dc:ff:ed:f3:a1 WPA: pairwise key handshake completed (RSN)
Fri Apr 16 19:20:48 2021 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED b8:27:eb:2e:83:59
Fri Apr 16 19:20:48 2021 daemon.info hostapd: wlan1: STA b8:27:eb:2e:83:59 IEEE 802.11: authenticated
Fri Apr 16 19:20:48 2021 daemon.info hostapd: wlan1: STA b8:27:eb:2e:83:59 IEEE 802.11: associated (aid 1)
Fri Apr 16 19:20:48 2021 daemon.notice hostapd: wlan1: AP-STA-CONNECTED b8:27:eb:2e:83:59
Fri Apr 16 19:20:48 2021 daemon.info hostapd: wlan1: STA b8:27:eb:2e:83:59 WPA: pairwise key handshake completed (RSN)
Fri Apr 16 19:25:55 2021 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED b8:27:eb:2e:83:59
Fri Apr 16 19:25:55 2021 daemon.info hostapd: wlan1: STA b8:27:eb:2e:83:59 IEEE 802.11: authenticated
Fri Apr 16 19:25:55 2021 daemon.info hostapd: wlan1: STA b8:27:eb:2e:83:59 IEEE 802.11: associated (aid 1)

I'm afraid this is just a temporary solution. After rebooting I have to change the settings again, which is obviously not a robust solution.
Any hints how the MAC Address could be changed permanently?

You could automate the process.
Change AA:BB... to the correct MAC address and insert the entire block in /etc/rc.local above exit 0.

sleep 30
echo "AA:BB:CC:DD:EE:FF" > /sys/class/ieee80211/phy0/macaddress
sed -i "s/bssid=.*/bssid=AA:BB:CC:DD:EE:FF/g" /var/run/hostapd-phy0.conf
uci set wireless.default_radio0.macaddr=AA:BB:CC:DD:EE:FF
/etc/init.d/network restart
3 Likes

Thank you, works like a charm :heart_eyes:

1 Like

The more structural way to set your MAC would be to do it in /etc/config/wireless. OpenWrt supports this so no need to do that through rc.local.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.