TP-Link RE350 unable to connect to Archer C7 v2

My wireless extender: TP-Link RE350 running v18.06.2 (not supported after this version)
My router: TP-Link Archer C v2, running v18.06.5 (still supported ie. 19.7.4)

The RE350 won't connect to the Archer C7 v2 running OpenWRT if I install any version from v18.06.6 and above on it. The RE350 works fine when the router runs on 18.6.05.

It seems that from v18.06.6 onwards, BSSIDs are handled a little differently. I found this on the v18.06.6 release notes for the Archer C7 v2:

This is at least for Archer C7 v2. The default bssids for the networks in my particular device are:

:::::*D for the 2,4 GHz radio and
:::::*C for the 5 GHz radio

In LEDE they result in

:::::*C for the 2,4 GHz radio and
:::::*B for the 5 GHz radio

The problem in LEDE is that the bssid set up for the 2,4 GHz is the one for 5 GHz and then the 5 GHz gets minus one.....etc

Unfortunately, since RE350 is connected to a CCTV and works perfectly, I rather not mess around with the extender's setup at all.

My question is: What changes could I make on the router running a newer version of OpenWRT and still get it to work again with the extender.

Thank You.

@Rose, welcome to the community!

I'm confused at why this is causing a problem, they're on 2 different bands. Upon upgrading they're changed, all is well, correct?

Or are you merely saying that you locked the CCTV's WiFi to the BSSID?

I'm not sure how that would be an OpenWrt-related issue, though.

  • If that's the case, you should be able to change/remove the BSSID (MAC) in the device setting
  • You could also just set the MAC to what you desire

Thank you for looking into this for me. I've included some additional configuration details that might help further.

Router (Archer C7) Wireless Situation:

Extender (RE350) Wireless Situation:

They did not help much.

From the pictures, I can only guess that you're using a DFS channel on the Archer. I doubt a CCTV camera would connect and operate very well - if at all.