TP-Link RE350 Back to stock firmware


I own a TP-Link RE350v1 and i'd like to revert it back to stock, but that has proven to be easier said than done.

I have already bricked and unbrocked my device (will post a tutorial on how to for anyone who needs the help), but the only firmware I can flash on it is the OpenWRT sysupgrade firmware (U-boot method - serial). Any version of the stock firmware or even the OpenWRT factory firmware fails and results in a boot loop.

I have tried stripping the firmware for this device, but the normal method of using dd if=orig.bin of=tplink.bin skip=257 bs=512 in a Linux shell results in the same thing, and using something like binwalk to try and check the contents of the bin results in what seems to be a corrupted file - likely from cutting out the wrong partition.

I have found stripped firmwares for the re200, re210 and even the re450 but none for the re350v1.

My question is, does anyone know how to correctly strip a firmware for the TP-Link RE350 (U-Boot 1.1.3) or have one on hand they can share?

Thanks in advance for any help.

Hi! How did you go about unbricking? I tried to strip the firmware myself but it just ended up in a boot loop... any advice would be appreciated!