TP-Link RE220 v2 - Unable to Install

I'm trying to install Openwrt on the TP-Link RE220 v2:


  1. I download Firmware OpenWrt Install firmware from the page above.
  2. Check the SHA256
  3. Upload the firmware file via the OEM GUI using an ethernet cable.
  4. For a short time the OEM GUI says "Firmware upgrading", then the OEM GUI says "Unable to upgrade."

I already tried renaming the firmware file to something short based on this.

Other Information:
OEM Firmware Version: 1.0.3 Build 20201022 Rel. 66896(8583)
Hardware Version: RE220 v2.0

To confirm, you should be using the "squashfs-factory.bin" firmware file if you are installing from the OEM GUI.

Rename the file "factory.bin" and try it.

Yes, that is the one I'm using. I renamed it "factory.bin", and had the same issue.

I'm not sure if this will help, but the sticker on the back of the RE220 says that it is version 2.8. Although the OEM GUI says the hardware version is 2.0.

The TP-Link site has V1, V2, and V3 firmware...

So for OpenWRT purposes, you are matching the version (V2 to V2) the OEM GUI says it's currently running.

I found a difference in the header of the V2 binary for the link above, (which is the link in the RE220 Techdata wiki), and the V2 version under the release folder.

Try the RE220 V2 firmware here...

It may be worth considering this further unless you don't care about 5Ghz. Since 5Ghz is completely broken on this hardware last I checked. And from memory going back to OEM is a bit of a faff.

That's unfortunate. I was planning on using it for a mesh network with my openwrt router according to this guide.

I might still be able to return the extender. Is there a different cheaper one you recommend?

Thank you, but that squashfs-factory.bin file has the same SHA256 checksum that the file I downloaded earlier does.

I suppose I could try to flash an older firmware image and then upgrade to the current version. But maybe this is a sign I should just get a different extender (see reply to @Lynx below).

Your call.

I would suggest an AP, rather than an extender.

Can someone else confirm about the RE220 (which is just the RE200 I believe)? It could be that the 5Ghz issues have been resolved now.

If not, seems such a pity because this is a really nice small and inexpensive device so would be great to have OpenWrt working on it.

This seems promising:


But if you scroll up on that thread you see problems reported with 5Ghz.

Also see here:

I am not aware of any other extenders in this price range.

It is a nice little device. Even though the 5GHz issue has been around for 3 years now it looks like it is being actively worked on as of this week:

@anon89577378 I agree that an AP would be better, but running ethernet through the wall would be difficult where I want to place the extender. Basically my garage has just barely enough wifi that my phone is still connected, but it is slow. So I'm unable to quickly download a Plex music playlist, an audiobook, or sometimes even a Google map from my car. That's really all I want to use the extender for.

I also hate cables.

So there is hope. I know it's not so desirable, but I can confirm that these extenders work well on stock firmware. OpenWrt is clearly desirable because you get 802.11r and 802.11s.

Personally I just run 3x RT3200's in a mesh / WDS setup. They are only 80GBP so still quite cheap, but not cheap as chips like the RE220. And bulkier. And overkill as an extender only.

5GHz issues aside, I did manage to flash Openwrt onto the device.

I first downgraded the firmware with the oldest TP-Link firmware I could find (firmware page, firmware download). After that I was able to flash the RE220 to 21.02.1.

I can look into the 5GHz later and let you know how performance is before the mt76 fix gets rolled out (God willing).

Please let me know. I think it will be useful for others wondering about using this device.

Here is my experience w/ re220.
Bought a new one, got v3, not supported :frowning:
Bought a reconditioned one, got v2, yay :slight_smile:
seemed to work ok, but now that you mentioned it I think uplink only worked on 2.4GHz, not 5GHz
Bought another reconditioned one, got v1, boo not supported :frowning:
Got a serial connection on v1, ran the initramfs version of v2 firmware, booted ok but 5GHz radio does not show up in Luci.


@Lynx a quick attempt seems to match @jedboy's experience. For a quick test I tried to use the extender in client mode. I was able to connect with 2.4GHz. With 5GHz I could scan for 5GHz networks, but when I tried to connect as a client it would not associate with the station. Which seems to confirm that the problem is transmitting at 5GHz.

1 Like

Such a pity as these are great pieces of hardware. Cheap and aesthetically pleasing. And with original firmware work pretty well (e.g. circa 80Mbit/s which is more than needed for most normal applications anyway).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.