TP-Link MR3020 v3 build problems


#52

Hello all,
Thank you for your help. I have done setting network configuration and my router is working well.


#53

Dear colleagues,
can someone share his built image with a network configuration? This will save many time.
Thanks!


#54

I'm having trouble in the make (6 part) part. Can someone share with us a compiled version?


#56

I've encountered the same problem. When I try the command "make", the three Warnings appear. I'm using Linux Mint as distro.


#59

I guess that kind of warning does not matter when you build it


#62

42

Link firmware : http://pulpstone.pw/beta-tester/ramips-mt76x8/

Added:
All Modem Packages
Support 3G/4G Modem
Support Protocol HiLink/NCM/RNDIS/QMI
Support USB Tethering Android
Support Exroot
Support SCP and SFTP Protocol
LuCI Theme Darkmatter
3G/4G Info by eko.one.pl

Basic Information:
Default IP Address: 192.168.1.1
Username: root
Password: root
SSID Wifi: PULPSTONE
SSID Password: internet

Big Thanks to meyergru


#63

@pilpstone
Can u please share the compile process for the image
Actually i want to create a custom image with some specifications like wifi settings and all.
since the old process was to create and a directory and put all config file in it, but in this lede build process i am unable to find how to do custom settings for my config files.
its been helpful for me if you share the build process.


#64

FYI: I created https://openwrt.org/toh/tp-link/tl-mr3020_v3 for documentation of this device.
It would be great if someone could fill in the basic hardware information and a short description of the installation process.


#65

Hi all,

I can confirm that pulpstone's build works like a charm. Also tested with 3G USB modem, ETH with DHCP or fixed IP, package installation.

Couldn't this build used as an official image, thus allowing immediate support for MR3020 v3?

I'm sure there's a lot of people in need of a openwrt version for this hw revision, and the official openwrt only mentions a link to this forum.

Can I help somehow ? Maybe in filling the install instructions of this build into the openwrt official page? What is necessary for it to show as a "supported device"?


#66

An official OpenWrt image downloadable from downloads.openwrt.org.


#67

Hello,
Do I understand this correctly, there is an official version for the TP-Link MR3020 v3?
I can't find the firmware at downloads.openwrt.org


#68

Hello, I just bought the TL-MR3020 V3 Today and sadly I had this problem as well
But I felt so good that there is other people having this problem as well
Hope we can have the firmware soon, I'm bookmarking this post :)))


#69

I'm reading through this post and have no idea at all how to do it :frowning:


#70

#71

Hello, Thankyou for reply,
.
.
I will try to explain as detail as I can how I got stucked
.
.
1. Set the Ethernet that the pc is connect to the MR3020 v3 by LAN cable
-Control panel > Network and Sharing Center > Right click on the connection > Properties
-Double click Internet Protocol Version 4, new windows open
-Check "Use the following IP Address"
-IP address = 192.168.0.255
-Subnet mask = 255.255.255.0
-Other leave blank
I got an error says that
The combination of IP address and subnet mask is invalid. All of the bits in the host address portion of the IP Address are set to 1. Please enter a valid combination of IP address and subnet mask.
I looked in this page
http://pulpstone.pw/beta-tester/ramips-mt76x8/READ_ME.txt
on the 11th line it says
"1. Configure PC with static IP 192.168.0.225/24 and tftp server."
so I try to setup IP as 192.168.0.254, not sure If I 255/24 you mean I can set to 254 as well, but it works
the new setting is
-IP address = 192.168.0.254
-Subnet mask = 255.255.255.0
-Other leave blank
.
.
2.tftpd32 download and setup .bin file
-I downloaded from this link "http://tftpd32.jounin.net/tftpd32_download.html"
-Version 4.52 "tftpd32 standard edition (installer)"
-It is installed at C:\Program Files (x86)\Tftpd32 (default)
-I use the file from http://pulpstone.pw/beta-tester/ramips-mt76x8/
-file name pulpstone-tplink_tl-mr3020-v3-squashfs-tftp-recovery-rev2.bin
-after download change name to tp_recovery.bin
-move tp_recovery,bin to C:\Program Files (x86)\Tftpd32 (default)
.
.
3.tftp upload
-Power off MR3020 v3 router, leave the lan cable connected
-Get the tftpd32.exe ready in another window
-Hold down reset button on the router
-Still holding reset/ Plug in power to the router
-Still holding reset/ as fast as I can > open tftpd32.exe in the PC
-I waited about 10 secs,the file should start upload but I got nothing
-Holding reset the router keep rebooting without upload from tftpd32.exe
-I tried other IP
-IP address = 192.168.0.255
-Subnet mask = 255.255.255.255
-Also not working
.
I didn't setup the tftpd32, don't know how to set it, and when I tried set it and reboot the tftpd32
the setting didn't keep, it revert to default setting

.
Please help~


#72

Look the video on 1.30! The correct ip-adress is: 192.168.0.225 and not 192.168.0.255 how you write...


#73

Omg I got it! Thanks!


#74

hey can anyone know the GPIO configuration for this v3 router


#75

Hello lede, could you please provide instructions to connect to board via UART


#76

Hi,

Do we know how much Flash and Ram are provisioned on the MR3020 V3?

Thanks