TP-Link MR3020 v3 build problems

I have cloned "git clone --branch TL-MR3020-V3" and build image successful. I renamed openwrt-ramips-mt76x8-tplink_tl-mr3020-v3-squashfs-tftp-recovery.bin to tp_recovery.bin for tftp recovery image, but after upgraded mr3020v3. the Internet LED always blinking. I tried to upgrade oem/openwrt images many times but no success.
Please advise me. thank you.

I got my's mr3020 back, I have striped 512 bytes form "" by using "dd if=oem_tplink-tl-mr3020-v3-tftp-recovery.bin of=tp_recovery.bin bs=1 skip=512" then update via tftp.
but when I tried with openwrt image from git, it is not running. Is it still work in progress?

  1. You absolutely need to use for your TFTP server for the recovery process.

  2. The internet LED will indeed blink after successful flash (see here), so no problem there. You should try to access the web interface of the box just as usual for LEDE (in case you have configured your image with LuCI).

  3. You do not need to strip anything from our recovery image - it is already stripped.

1 Like

Now everything works as expected, just compiled and installed LEDE on MR3020 V3 using meyergru's repo :smile:
I really don't know why it was not working, i've double checked I'm in the same branch, same commit in both directories. The former has only a different directory name..

Well, nevermind, thank you :slight_smile:

I also confirm that the builded image from meyergru github didn't work. My PC didn't get ip address from the router. I set my PC ip address to automatic. I'm building using default config with mediatek Railink mips as target, mt76x8 as subtarget, and TP-LINK MR3020 V3 as target device. @meyergru can you show me the right step to build working image?


I don't know your network setup, so I can only guess: AFAIK, LEDE has a default address of I don't know if a DHCP server is even active at first boot, i.e. before the initial config has been done. Also, I think that in the LEDE default setup, LuCI is not contained. So you may have to tweak your LEDE configuration.

I can assure you that my modifications do in fact work. I assume that you'd have the same problems if you would try to setup another hardware type with LEDE. I use the very same modifications for my own product HomeTunnel, albeit with a given network setup and additional software.

As you can see, Giuglio did manage to get it going after initial problems as well, so I doubt that there is a specific problem with my modifications.

Remember: your PC keeps the assigned DHCP address for as long as it was obtained, so I would rule of the DHCP part altogether by assigning an IP of, say to your PC and trying to access That is, if you did not forget to reconfigure your PC from the address you had to use to initially flash the device.

Thank you for your reply. I will try your advice. I'm not at my PC right now.

And also, do i have to "git pull" command after clone your repo in my buildroot directory? Thanks.


No, the cloning of the branch should be sufficient.

After I change my PC ip address to I'm still not having response from the router. Pinging got Destination host unreacheable.

hello, thank you for your advise.
The following steps are how I build LEDE image from git.
1.$git clone --branch TL-MR3020-V3
2.$cd lede-source/
3.$./scripts/feeds update
4.$./scripts/feeds install -a
5.$make menuconfig
I have created LEDE image from both Debian 8 and Ubuntu 16.04.
After flash via tftp, I captured activity on LAN and found that mr3020 is still in recovery mode.

Did you get it working? If it this, can you upload the firmware?


Not yet, I don't have working image. @meyergru can you please share LEDE working image with us?

I can confirm @meyergru 's fork is working with my MR3020 v3. I've just built the image including some config file.

@doxigin sornchai
You can generate your very own config files by hand or by getting them from a running openwrt distro on similar hardware (ex: MR3020 v1)
Then you can embed them in a custom-image using the image builder you can generate from @meyergru 's sources. More infos here:
If you are still in trouble I can try to get and upload my configurations.

1 Like

Thank you very much @Guglio for the confirmation. I'll using image builder. And if i stumble along the way i'll post here for help.

Much appriciate.

Thank you @Guglio for the hint. I manage to get it working. Thank you very much.

1 Like

I don't know why my build image is not running. I tried also using image builder but no success.
The Internet and WPS/reset LEDs always blinking. please advise me. Thank you.

As stated in the link by @Guglio basically you got to have a network configuration of a working mr3020 any version. Just Google for example. That's what I did. And then you follow the steps in the link. Hope it's help.

I only use repos from @meyergru and then I created folder named files/etc/config. Put the network configuration file and build

Hello all,
Thank you for your help. I have done setting network configuration and my router is working well.

1 Like

Dear colleagues,
can someone share his built image with a network configuration? This will save many time.

I'm having trouble in the make (6 part) part. Can someone share with us a compiled version?

1 Like