TP-Link MR3020 v3 build problems

opkg install --force-depends .......
but it's a little wrong

Maybe you can help me?
I flashed pulpstone, but there was an error with php-cgi. It use fopencoockie, but there is no fopencoockie in your system. So php-cgi doesn't work(

It doesn't work.

uinstall all php7 from default repo.
change your repo from snapshot to releases 17.01
install php7 from this repo
have fun :grin:


I'm trying to compile an image for MR3020 v3, but failed so far.

I've chosen the base system, target profile and subtarget per your suggestion. Yet after make I cannot see factory.bin in bin directory. Only upgrade.bin.

Normally, with MR3020 v1's image, if factory.bin is not there it's because the package size is more than the ROM size (~4Mb). That's why I've deleted many packages, including opkg, luci, tc, ipset and many more, but still no success.

What should I try next?

make V=s to capture "full" output -- don't add any -jN flag so that it is single-threaded or things won't make much sense.

I'm using make V=s actually. Unfortunately though, nothing seems wrong from the output.

This fork of openwrt by meyerguru for V3 can be compiled only in sysupgrade.bin and tftp-recovery.bin format. You cant upgrade from basic tplink software to openwrt. Only way is to use tftp-recovery.bin and tftpd32 soft. After you can upgrade by using sysupgrade if you need.

1 Like

MR3020v3 + Luci + block-mount + usb storage - Ipv6. Compiled from meyergru fork

Snapshot support for TL-MR3020 v3 has been added:;a=commit;h=6bbb2202551be394fead2efd99eb946f846fc63d


Did anyone managed to find how to control USB port power on this device? On v1 it was possible through GPIO #8, but on this one none of 96 GPIO's seems to be realted to USB port power.

Hello, I have tried this with no luck.. All LEDs are flashing repeatedly and continuously..

Then I tried "stripped original firmware" from here, but again it didn't work.

Any other options that I should look into?

I expirience weak wifi signal and connection loss on multiple v3 devices when connected as a wifi-client.

1 Like

I'm having the same problems. Have you found any kind of solution for this?

To everyone here having issues, please

  1. TFTP OpenWRT (See instructions and warnings ITT above) over the TP-Link firmware
  2. Then upgrade to the latest OpenWRT snapshot using Luci -

Everything works fine for me on -

Hi Dmitry Chigiryov,

You can use the following script to control the USB port power:

for port in /dev/ttyUSB*
     echo -ne "AT+CFUN=1,1\n\r" > $port
     if [ $? ==0 ]; then
1 Like

Hello everyone.
I managed to install pulpstone-tplink_tl-mr3020-v3-squashfs-tftp-recovery-rev2.bin at my mr3020-v3
Now, I need to custom a build with some files and packages
With mr3020-v1.9, instead of compiling the firmware, I did it using ImageBuilder
Does anyone have made ImageBuilder for this pulpstone firmware ?

A post was split to a new topic: TL-MR3020 v3 WiFi + LED problems

This topic started with "Lede has no profile for 3020 v3".
Since support for the TL-MR3020 v3 has been added in August and a profile is available, I'm closing this topic now.

Please open new topics for any specific questions regarding this device.