TP-Link MR200 firmware update

#61

Just to be clear, you (usually) don't have to use tftp for upgrading OpenWrt to a new version - you just take the sysupgrade image gurangax linked to above and either upload it via OpenWrt's webinterface (luci) or upgrade it with sysupgrade from a ssh/ serial shell.

0 Likes

#62

Thanks, and after that, what file or what I could do to flash again TPLINK firmware? I want to do it now to I will learn with you how I have to do in future.
Remember that with my last MR200, I lost lan ports. In openwrt know they are working perfectly so what file "back to stock" do I have to upload from luci ?
Thanks

0 Likes

#63

I would rather flash with tftp to go back to original tp-link firmware. You need to strip the tp-link firmware you wish to use as mentioned in the recovery page, and rename it to ArcherC2V1_tp_recovery.bin. This file must be correctly made or you will soft brick it. Let me know if you need such file.

It is better to save the bootlog first before doing this

0 Likes

#64

Did you know that we have a wiki that answers many questions?

https://openwrt.org/toh/tp-link/archer-mr200#reverting_back_to_the_stock_firmware

0 Likes

#65

@gurangax and @tmomas thanks a lot for your help.

I have read again all this post.

Gurangax you said (post 5):

If you wish to revert back to the original tp-link version you can use back_to_stock firmware with the webgui. If you can't update with official tp-link firmware after back_to_stock then something is wrong with the firmware but it can still be corrected. I can prepare the correct file if you need it.

Also in post 23:

I decided to duplicate what you have done.

  1. flash tftp using the mediafire link - everything including LAN is ok - system was openwrt 18.06.1
  2. flash back to stock from openwrt webgui - LAN becomes dead and my router wont fully boot since it wants to find the original modem which is broken, so I can not test flash by wifi

In order for me to restore it, I used an external programmer. LAN is now ok. Everything is working again. So it is the back to stock firmware which is giving the problem, your LAN is not broken. It may be fixed by firmware update. Like previous post you can try first update by wifi with older/oldest version from tp-link, then see if your LAN is working again.

In post 56:

it is better to save the bootlog before any updates for reference

In my old MR200 I flash openwrt with TFTP as I have done yesterday. In openwrt I have lan ports working.

In my old MR200 I flash with openwrt webgui the mediafire file "mr200_back_to_stock.bin" but after tha lan ports didn't work.

Today I have the new MR200 with openwrt,and I want to flash with webgui a "mr200_back_to_stock.bin" file ( a good one).

Where I can find this file? I have read about @tmomas said, but i dont feel confidence with that kind of changes. If I do it wrong, I think that I coud brick my device forever.

Is there anything that I could do/check with openwrt not to brick my device after trying to flash a "back_to_stock" file?

But, @gurangax said:

I dont know what are you trying to explain me:instead using a mr200_back_to_stock.bin filefrom openwrt webgui is it better to use another ArcherC2V1_tp_recovery.bin file from an official tplink firmware to restore MR200 back to stock?

I want to do the safest method, but I think that i could brick my MR200 both ways (webgui and tftp) couldn't I ?

Also, @tmomas said about a third method https://openwrt.org/toh/tp-link/archer-mr200#reverting_back_to_the_stock_firmware, didn't he?

What do you think guys? What is the best way and the safest way?

Thanks

0 Likes

#66

I am considering using a different file than mr200_back_to_stock.bin. I consider it as old and I am not sure if it is the same file as the original one posted years ago, since I was having problem with tftp after flashing with this file now. The bootloader seems to be problematic. So I suggest to do it manually by stripping a tp-link firmware and flash by tftp.
There is no safe method for reverting back, all depends on the firmware you are using to flash. If the bootloader is wrong then you will brick it. And as I said, I prefer tftp method.

Anyway let me know if you need help stripping a tp-link firmware correctly. There is probably a way to flash via openwrt webflash any stripped tp-link firmware by using openwrt tool somewhere, forgot the name but the function is to add a tp-link header to the firmware.

0 Likes

#67

If you preferTFTP method I think it will be better. I feel confidence with TFTP method as I have done already twice,.
The problem here is to get to good bin file, if I choose the wrong file, I will brick my device, won't I ?

Thanks

0 Likes

#68

Yes, which version do you wish to use? I can make you a Archer MR200(EU)_V1_180502 version of tftp recovery file if you need.

0 Likes

#69

Yes,thanks.
Three last questions

  1. with that file a friend of mine with an MR200V1 with a custom company firmware (internet provieder) could be get an official MR200V1 firmware ? I understand that the hardware is the same. I have always read that people who want official firmware needs to flash first openwrt and after that back_to_stock file, why not flash directly back_to_stock? Or am I understanding it wrong way?
  2. I still don't understand why the mr200_back_to_stock.bin fila that I used with the old router disabled lan ports. May be that file is for different hardware version of V1 ? Why some peopleget successand I not? I don't think that my old provider specific firmware MR200 would have different hardware from an official MR200 router.
  3. Abusing your kindness and knowing that you are able to flash the SOIC8 chip, could you verify that the file works correctly via TFTP? (if it goes wrong, you can fix it, but in my case, if the file is not good, I will have a prefect bricked MR200 forever)
    Thank you again
0 Likes

#70

When you use TFTP recovery, it doesn't matter what firmware is presently installed in the router. The TFTP process occurs before the installed firmware tries to boot up at all. It's intended to replace firmware that has an error in it and can't boot.

To be sure you're really completely back to stock after flashing some third-party prepared "stock firmware" it's a good idea to do a reset to factory settings, then download a copy of the latest stock firmware directly from the manufacturer, and flash it again.

0 Likes

#71

@ortegafernando

You have a custom firmware from your ISP, when you do a flash upgrade the ISP data partitions are still there and not replaced, and this could lead to problems that you were having. The best way to convert your custom device into TP-Link original is to flash it with an external programmer, with the correct full firmware dump which is available.

We still don't have confirmation if the file mr200_back_to_stock.bin is still the same file it was originally posted. I only encountered this problem when I attempt to compile the GPL code for the bootloader and used it as my device bootloader.

I don't think your device is bricked forever, it just need the correct firmware dump

0 Likes

#72

Hi again

I understood reading https://openwrt.org/toh/tp-link/archer-mr200 and seeing "Flash layout" table and back_to_Stock file that I have (7872kb) that with TFTP method flashed every "important" partition, as others will be related to hardware and I think that the official hardware and custom ISP hardware is the same. Sorry for my misunderstanding.

For my friend, then, it is better NOT to flash the "back_to_stock" file though TFTP, is it ?

I don't exactly understand you. I flashed a file from mediafire with a MD5: b327193f8e50fde228c681108fb33353, with that file, my old ISP's mr200 got lan ports unusable.

So, please, prepare a file with the last firmware. Could you check it on your own router? Thanks a lot.

1 Like

#73

Flashing only change some partitions, not every partition, your ISP partition is no change. You can only write full partition with external ROM programmer.
Back to stock is meant for webflash with luci, not tftp. Some times ago the LEDE website was experiencing some problems with the forum and some files/posts was gone, so I am not sure if this was also affected. You can ask the original poster about this file.
Here is a link for use with tftp to go back to original TP-Link version 160905
http://www.mediafire.com/file/jkfa82kjwlt8eaz/ArcherC2V1_tp_recovery.zip/file

0 Likes

#74

@gurangax

First you say that "back_to_stock" is meant for webflash with luci.

After that, you have give me a link for a file for flashing with TFTP (160905 V1 versión)

I will download this night the file that you linked and check md5.
With TFTP if the file is not good for my hardware ... I supposed that I will not break my lan ports like last time with the old router? With webflash with luci, in my old router, I "broke" my lan ports. Could I get the same problema with TFTP? (I mean, does TFTP and LUCI flash different partitions, or all the same?)

Thanks

So there is no option to flash back_to_stock from

0 Likes

#75

@ortegafernando

Please understand, whichever flash method that you use will have the same effect if the firmware is faulty. The fault is not in the flashing method but the firmware itself. Please also understand that "back_to_stock" file is not recommended by me simply because I will not be able to use tftp after flash with it. You may be able to use webflash with it, I can not guarantee it.

I have provided you with the file to revert back to stock tp-link, this is one of options to flash to stock.

0 Likes

#76

Hi, this file's md5 is: 7ee0e69a81e1e346d6f7cc4956b8d32f
So it is different from the old one.

I want to ensure myself:

  1. your file is for TFTP flash method, so it will be almost impossible to brick my router. If anything is wrong, I could flash again with TFTP the openwrt firmware, couldn't I ?
  2. this file could be used also to update a ISP router to an official tplin firmware, couldn't it ?
  3. Have you finally check this file in your router? PLease help me.

Thanks.

0 Likes

#77

of course its different, its not even old one. please don't compare them. The old one (back_to_stock) is not from me.

  1. If during firmware flash you somehow have power failure then you will brick the device. This will also happen with any firmware.
  2. This firmware is not to convert ISP to stock TP-Link. It is a stock firmware itself. You want to convert ISP to stock use external programmer.
  3. I have checked with my router no problem. I will not post a file if it is not working.
0 Likes

#78

Thanks a lot. I will try

0 Likes

#79

Hi guys.

I'm back again, sorry for the delay.

Finally i desoldered rom chip with my hot air gun.

I read it successfully and made a dump file.

MR200V1_Amena_dump

I used a ch341a miniprogrammer and soic8 adaptor like those:

ch341_miniprogrammer

Soic8_adaptor

I read it twice with two different sw, AsProgrammer_1.4.0 and Ch341_Ver_1.34.
I made a comparison to be sure and was successful.

@ortegafernando, i hope it would help to you.

Good luck.

0 Likes

#80

Hi @ortegafernando, @Gurangax

I have good and bad news.
After desolder rom chip.
I successfully flashed it without issues using my CH341A miniprogrammer.
But after reinstall the chip i have no success with stock dumps.

I explain my process as following:

1.- I use C2V1Stock_dump, posted earlier in this thread. Results:
- Router won’t boot
- No power led
- No 4G led
- Lan ports didn’t work
- Only wifi led lights on.
- Reset/WPS button Works, if i long press it router
reboots and if short press it WPS led lights on.

2.- Then i tried Heinz firmware Archer MR200 dump from this link. Results:

            - Router won’t boot
            - Any leds ligths on.
            - No lan, no wifi, no 4G.
            - Reset button press, nothing happens.

Each test involved desoldering and soldering rom chip (4 times) so that i thought i have fried the pcb router.

At this point only i could do was to restore my ISP backup dump, delete any evidence of manipulation, and send it to the SAT, because it is still under warranty, and pray.

But, surprissingly the ISP backup flash restored my router, all working like a charm.

I don’t understand why the 2 stock dumps doesn’t work. I think it is related to driver version or hardware difference, i don’t know because the back sticker shows “Archer MR200 ver:1.0”.

I want to upgrade my router to openwrt fw through tftp, but i’m not sure if it causes LAN port not working or something similar.

I read (with translator) at this polish fórum thread a Heinz post, that tells is posible to rewrite the 3 last partitions mtd3,4,5 through uboot with uart-ttl connected to serial port, but i don’t know how. But the question is what mtd3,4,5 partitions are the correct one.

I don’t know if there are any way to know what’s the differences between the ISP dump I posted and the stock dump, in order to know why stock dump doesn’t works, or to make a safe hybrid version, that allows to upgrade with oficial TPLINK fw.

But, at the moment, i will not try to do any flashing again, until i manage to flash the chip without having to desolder it using soic8 clip, the test desoldering and soldering the chip are very risky and I have reached my limit, 3 desolders and 3 solders are enough.

Best regards.

0 Likes