TP-Link CPE510v1 not reachable after sysupgrade

Hi all,

I flashed a TP-Link CPE510v1 with the latest snapshot image and I think something went wrong and I can't reach it anymore.

It had an older version of OpenWRT on it, and I flashed it via console accessing it via ssh. I had to run sysupgrade -F -n cause I was getting the error about the binary not containing a list o supported devices (Although I'm sure I downloaded the right image)

What happens now is that:

  • I power on the TP-Link and connect to it's lan port directly from my laptop
  • the laptop sees the antenna and self-assigns an ip
  • I don't know what the ipaddress of the router is....

I tried:

  • setting the ip addresses manually from the laptop
  • accessing as OpenWRT default
  • resetting the device with the reset button, but it doesn't do anything (no flashing or stuff)
  • booting the device in failsafe mode (also in this case no flashing of leds and stuff)

Any ideas to try and recover it?



What do you mean by that ? The router offers a wifi ?

factory or sysupgrade image?

No, but comnexting it via ethernet the laptop detects an ethernet connection and assigns itself an ip


Hearing "older version", I assume it was an old ar71xx image, and now you have flashed an ath79 image.

Did you follow

Have you tried to connect on both Eth ports, or only on one?

Ehm actually I said older but it was actually just a different build, but still an ath79 (a build a friend made with some default configs in it and a bunch of stuff I wanted to get rid of with a clean install...

I didn't read that post no... but I guess I wasn't careful enough when putting that -F flag...

I tried connecting to the port on the antenna and the port on the power adapter (which I guess do the same thing?)

What do you suggest at this point? Following the article you linked I guess the last chance is to try flashing through TFTP...?


I can confirm this. The OpenWRT 19.07 ar71xx image for this device works, but the current snapshot ath79 image won't even boot. I flashed the "factory" image using the TFTP method in both cases.