TP-Link CPE510 V3.20 EU snapshot build broken

Snapshot build does not work for this device. I tried to install it today via web interface and TFTP, but after that it just got stuck on boot with the power led on, nothing else. No ssh access, I tried, and also, but without success. After that I installed stock firmware via TFTP and it works. Any suggestions?

And if you try to install 19.07?

Unfortunately, there is no 19.07 stable build for this device, only snapshot. I also tried 21.02rc snapshot but it is also broken.


In that case, the only way to see what's actually happening, would be to attach a serial cable to the unit.

Is there any snapshot archive repository for ath79? I'm sure I read some post that the device worked fine with openwrt snapshot build a few months ago. I am currently using tp link firmware and it works fine, but the drawback is that I can only use DFS channels in client mode since it is an outdoor device, so I can not connect to indoor AP or if I use it as AP, devices which using non DFS channels can not connect on it. I found a workaround for that, but it would be great to have openwrt on this device.

not that I'm aware of .... :frowning:

Just to confirm, snapshot build from January works on this device, I found it using I flashed successfully, also got the internet connection but I can not install luci on it since it is an outdated snapshot build. After that, I downloaded the latest snapshot again and make my build including luci but without success. After flashing, device just stuck forever before reboot with all LEDs turned on and when I force reboot, it just stuck with the power led on and nothing happens.

If you're able to grab an image from a certain date, DL the modules you need from the same page & date, and opkg install them manually directly on the unit (opkg install packagefilename)

Try to sysupgrade from the working image, to the most recent snapshot.
You'll be able to install luci + etc, during a 24hr window, until the next snapshot overwrite the old one, along with all the packages.

do you have a serial connection ?
would be good to know what fails with the newer images.
There's no point in opening a ticket, if we can't pinpoint the issue.

Unfortunately, I don't have a serial connection. Today I tried all possible options including sysupgrade from the working image but still nothing. After update, the device stuck with only power led on. But actually, I found a solution for my needs. I managed to set up everything I needed without luci, directly via ssh and this snapshot build from January works just fine. It works more stable than stock firmware, all channels are available now but there is also a drawback compared to stock firmware. With openwrt, I have 10db weaker signal (the device is in the same place) and 20% slower speed. Region and TX rates are set correctly but the signal is weaker significantly. Anyway, I think I'll be happy with this as is, until openwrt port an stable build for this device. If anyone needs this, until now, the latest working snapshot build for V3.20 I found is from January 21. 2021.