TP-Link CPE510 Link Problems on PtMP since 21.02.0-RC4

Hello everyone, greetings from Italy! My first topic and unfortunately I'm asking about a nasty wireless link problem that's affecting my PtMP (point to multipoint) setup.

3x TP-Link CPE510 HW V1.1 flashed to OWRT 21.02
All are configured for WDS operation.
Node 1 (base network, internet connection): WDS Client
Node 2 (Ham Radio station, branch network): WDS AP
Node 3 (auxiliary station, second branch network): WDS Client
It started in 2017 as a PtP with Node 1 WDS AP and Node 2 WDS Client, but I needed a third node and converted Node 2 (atop a 12-floor building) in a sort of repeating station to connect Node 3 to the internet (Node 1).
Node 2 to 1 distance: 950 m
Node 2 to 3 distance: 510 m
It's a "V" shaped path so Node 1 and 3 can't see each other directly.
Using 802.11n HT20, I need more link stability than bandwidth.
Using WPA2-CCMP with additional station MAC filtering on AP.
Using OWRT 21.02.0 in various releases.
All wireless settings to default, distance optimization 1000.

Problem is: up to 21.02.0-RC3 everything worked fine.
Upon updating to 21.02.0-RC4 I found out that WDS AP mode seems to be at least partially malfunctioning, client stations connect and authenticate correctly but downlink rate from AP to client stations remains fixed at 6.0 Mbps whatsoever, no network connectivity.
I tried almost everything I could think of to try and found the cause of this, disabling security, disabling MAC filtering, changing channel, tinkering with 802.11w, to no avail. Sometimes changing a setting makes it work, but all I need is a reboot of one node to break the link again. Sometimes I can get one client to work with the other stuck to 6.0 Mbps and no connectivity.
The settings that seem to work best are WDS AP in WPA2-PSK 802.11w DISABLE and WDS clients in WPA2-PSK 802.11w OPTIONAL but even these do sometimes fail and are not reboot-friendly (branch stations have all UPSes but I need them to be able to reboot without having to get there to operate locally).
Same problem happens with 21.02.0 stable.

I have three brand-new CPE510 stations at home, two are HW V3.0 and one HW V3.20. Flashed all of them correctly to 21.02.0 stable for V3 but I'm experiencing the same problem, on a test PtP link of 2 m at 0dBm power, I can get 300 Mbps uplink but 6.0 downlink, sometimes rebooting solves yelding 300/300, more often not. WDS AP reports 6.0 Mbps, WDS client reports 0.0 Mbps but remains authenticated.
To me it seems like a ath79 or AR9340 driver issue or some nasty setting introduced with RC4 that breaks WDS on these CPEs.

On a side note, with RC3 I tried configuring the main PtMP in WPA3-SAE 802.11w "1" (optional) and it works flawlessly.
I really hope in some advice on this, I really like Owrt. Regards!

There seems to be issues with WDS currently. There is a patch here you could test out here:

Or your could try 21.02_RC3. WDS worked fine for me with that release.