TP-Link CPE510 - can't revert to stock

I recently bought (2nd hand) 2x CPE510 to make a p2p link. They came with stock firmware, can't remember but it was below 1.3.3.

I left them connected overnight as a test and to my surprise one of them was rebooting in endless loops in the morning. I tried many times the recovery process with TFTP using several tp link stock versions for this CPE, but the result is always the same: it boots, I get 4 or 5 pings fromm and them disconnects and reboots.

Now the strange thing is that if I load an OpenWRT firmware the CPE accepts it and works! I even tried Gluon firmware, also works nicely. Only stock Tp Link does not :frowning:

What could be the cause? I suspect something related to power outage could have happened during the night and triggered the problem. Maybe a partition problem somehow? Any ideas how I could make it work again?

did you try to reset it to factory settings?

Yes, sure. Several times.
I did almost anything you can remember. Tried TFTP in Win7 and Win10. Used a LAN switch in the middle. Tried both LAN0 and LAN1 (my CPE510 is V1.0 with 2 ETH ports).
Tried resetting with a pen. Nothing works.

It seems the internal memory suffered some problem that only affects the stock TP- LINK firmware. OpenWRT can be loaded and booted ok.

I would like to avoid opening the case to solder any wires to see the output on serial port (if it exists).
However, as I can flash successfully with OPenWRT (that's the present situation) I do have access to SSH / terminal window.
How can I check about the partition tables or filesystem? It's just a hunch, I suspect I need to re-aarange the partitions or filesystem so the stock firmware works again.
I'm relatively inexperient with linux, so I don't want to format / erase any thing in the wrong way.


I tested another firmware:

So now, I have 3 different firmware that work: OpenWRT, Gluon and AREDN. Any of these can be loaded and booted successfully via TFTP method.
Only TP Link Stock Firmware refuses to boot on this CPE510 unit. What could be wrong ?!

While in OPenWRT, via terminal, I've tried to run:

"umount /overlay && jffs2reset && reboot now"

But didn't make a difference, I can't load again PharOS. Any idea deeply appreciated, I'm running out of ideas.