Tp-link cpe210 v1 brick?

Hi all. I tried installing openwrt on my cpe210 some time ago and I soft bricked it. I unbricked it succesfully and gave it a rest for months.
But today I tried again with openwrt-19.07.7-ar71xx-generic-cpe210-220-v1-squashfs-factory.bin and I bricked it again.... :frowning:
But now here's no tftpd request in Wireshark..... but it does find a packet containing the word "openwrt", so I still have some hope that it's not dead.
As far as I understood the DHCP was supposed to be working after install and the AP should be 192.168.1.1 ,but it's not working and I don't get an IP..
After that, I was hoping to find a static IP that I could put in but couldn't find anything...nothing on the internet.
So is there a static IP?? What can I do? It really doesn't look it's truly bricked...
thanx

192.168. 1.1

Set a static IP on your client, in the same subnet.

If still no go, serial console might help, assuming there is one.

I've already tried the obvious 182.168.1.x and 182.168.0.x....
Hmmm so I sould take it apart......? That can't end well :stuck_out_tongue: Then again...I have nothing to lose...
But I don't understand why I keep bricking it if I use the firmware that is suggested here....I tried an older one and that didn't even upload..

Ok. I made progress. I had an arduino lying around and managed to serial connect with it after many trials and errors. It does have openwrt and it is alive and well ! :smiley: But it only works via serial. Now I'm trying to revert to the original firmware, but every tutorial I read/watch they use tftpd and I don't have that on the router.. Stuck again
Any ideas??

*edit. nevermind I found these commands and installed the GUI from within.
opkg update
opkg install luci
What a ride! 13hrs spent digging and discovering stuff...If I knew what I had to do, this would have taken me 15minutes including the wiring which I didn't even bother soldering :smiley:

WOW!!!!!! Seriously???

It turns out that if you connect the ethernet cable DIRECTLY to the CPE it doesn't get an IP! But if you connect it to the POE adapter's LAN it works!! SERIOUSLY NOW OPENWRT?? I spent 13 hours trying to solve this and it never crossed my mind that it this could be the problem!! On the original "dumb" firmware you can just plug the cable anywhere and it "magically" works, while with the "smart" firmware it doesn't! I'm really pissed off!

And now that it's in client mode (internet by cable from router and cpe acts as an AP) I can't access LUCI and it doesn't even show up in the router's connected devices so I can get it's IP (probably it doesn't get one...) So how am I supposed to access the CPE and run the commands I want?

That might be a bug...

Serial console dumps would probably be useful.

Not a bug... I discovered yesterday that it was switched off by default, in the switch section. I never even knew what a soft switch was, until yesterday. Why would the devs have this off by default (and without a warning text in the install procedures or in the AP its self) is beyond me. I found the solution by mistake when I read about a guy with fried ports, looking for solutions..
So basically I wasted countless hours full of frustration looking for complicated solutions for nothing... I reinvented the wheel..
Well at least I made a serial connection using an arduino and used SSH for the first time.. I probably would've never scratched the surface if everything has worked flawlessly. Now of course I can also find the AP even in the feared bridge mode...
Now I need to continue into the rabbit hole and demystify NAT, routing and firewall.. :smiley:

I have had numerous TPLink routers and managed to brick one or two.

I do not think that you are being entirely fair to OpenWRT, it is not a manufacturer or even commercial organisation.

The documentation looks great and the forum archive shows the birth and evolution of support of your device.

https://forum.archive.openwrt.org/viewtopic.php?id=55907

A few of the TP link devices I have had shared some ports as WAN connections and under stock firmware were often flaky.

I think you can contribute to the wiki if you learn anything, check at the bottom of the documentation for how to submit content to it.

Great to hear your story because it shows the learning experience, I am a total newb but learning from posts like yours.

Yeah you might be right (in a way..they're not official)) but the concept should be simple. .. the new firmware should emulate the original one and have everything working like the original. Then have the ton of configurations available to change if the user wanted. The people working on this are mad scientists in my eyes and I tip my hat to all of them, so this "mistake" has no place here. It's unfair for them..
I've read the link you provided (before posting) but that thing is dead for a long time and it didn't seem like a lot of help for the others that asked questions there. I read tons of pages on here and elsewhere before posting cause I didn't want to be the noob that whines at the first hiccup and doesn't read before posting.
That was my goal with continuing my story..I hoped to help someone. I might do the "formal" thing that you suggested too. (if I find it) Am I looking for the CPE wiki or the general one?

I wonder if I can edit the title and add [solved]
Couldn't find something

Are you seriously saying that the developers should go to each modem, look at the firmware and design a front end that emulates it?

I would not say Dev's are mad scientists but rather talented engineers and programmers who give their time to create something better, something that allows users to get the best out of the hardware.

If you get your router back or decide to move to a different one, you have two choices, either get your head around how OpenWRT works or use something like DD-WRT that gives you far less configuration option but is better than stock firmware, that is assuming it is supported by them.

Also the part of the modem that you are having a problem with is not OpenWrt but the code hardwired into the hardware. Imaging how easy it would be if we had a serial port at the back of every modem.

It can be very easy to brick a router or other device, they tend to not handle errors very well.

Bricking and recovering a bricked router is a general thing, here you are lucky that some have documented their exploits.

Personally, I value my time, so once it gets to soldering or unbricking I would rather put the device on eBay under for parts or not working and get myself another router (also from ebay).

You can mark any thread as the solution or it will close 10 days after the last comment.

When I say emulate I mean that if on the original has two working ethernet ports by default, openwrt should have two working ports aswell. And if not, at least have a warning that it's closed, just like they warn that wifi is off by default.

A convention within OpenWrt is that devices with two or more Ethernet ports will default to one is wan and the rest are lan.

The wan network is a DHCP client, not a server, and it has a firewall against all incoming connections. So plugging your PC there will not be useful.

The port numbers or names may not always line up with the manufacturer's designation under stock firmware. This is one of the finer points that may not be fully dialed in for every model.

1 Like

With respect, I think that you are missing the three greatest aspects of OpenWRT.

  1. A common user interface so you only have to learn the layout once.

  2. The ability to get under the hood and create things the original firmware does not, e.g. splitting the Lan ports into 2 x 2 vlans.

  3. The ability to tweak the hardware and take advantage of hardware capabilities that the OEM firmware chose not to use.

I was configuring a router for someone a few weeks back on their stock firmware.

It has no option to install a wireless bridge, yet OpenWRT allows numerous different types of wireless bridge.

It also had not firewall, no ability to set routes.

As for your two working ports example, I see the switch screen and it mirrors the router. Under the hood the config has coded how it addresses these ports, but usually they just work in a default manner.

The same way a wan port works like a wan port.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.