TP Link C2600 not hitting 1 gig download


#1

I'm on 18.06.02 build. I have 1000/35 plan with Comcast. My max download speed so far is around 450 down. Is there a switch I need to hit or a knob to turn? Both software and hardware offloading are checked off. Here's my current configs:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd81:8721:b298::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '1.1.1.1 2606:4700:4700::1111'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option peerdns '0'
        option dns '1.1.1.1 1.0.0.1'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option peerdns '0'
        option dns '2606:4700:4700::1111 2606:4700:4700::1001'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'
        option vid '2'

#2

1 Gbps is quite a stress on any consumer-grade router. That said, 450 Mbps seems low for a router with a moderately powerful SoC.

Have you checked that your modem has sync-ed with sufficient parameters to support 1 Gbps?

I'd try turning on offloading (as well as disabling SQM, if you have it enabled) as a start.

After that, if you're not quite saturating the Ethernet link, you might want to enable bonding on your modem and router both, running two cables between them. I don't know if that will help when your router only has two Ethernet interfaces.


#3

Oops, I meant to say offloading for both software and hardware are checked on. My modem is a Docsis 3.1 so definitely supports 1 gig+ download. I don't have SQM installed. On stock OEM firmware, it hit 900+ mbps before.


#4

Although probably not an issue, as the device does not support HW offload, you may want to turn the feature off.


#5

ipq806x is throughput limited to around that order of magnitude (ipq8064 a bit more than ipq8065), while there is the chance that the NSS/ NPU cores might be supported one day (used for offloading the networking from the main CPUs, which should provide a significant speedup), that will take considerable time to get sorted (and may never happen at all).

Without offloading to the NSS/ NPU cores, ipq806x is good for ~350-400 MBit/s of WAN throughput, up to ~600-650 MBit/s if you tune it well (software flow-offloading), beyond that you need a faster SOC - mvebu and x86 would be the primary candidates.


#6

You have 3.5% upload speed compared to the download speed. It is little brio.


#7

Yes you could have ACK starvation in addition to all that other stuff. Try turning ON SQM in the upload direction only, and set the ack filter option.


#8

1000/35: Bad proportion.


#9

Yes you could have ACK starvation in addition to all that other stuff. Try turning ON SQM in the upload direction only, and set the ack filter option.

I don't see the option to turn on ack fliter option. Or can't find within the GUI.


#10

Yeah it's an advanced feature requiring you to enter the raw option in a text box... The option is called ack-filter and goes in the text box for egress options under the really really advanced options in Luci. You can see the sing and dance section here

https://openwrt.org/docs/guide-user/network/traffic-shaping/sqm-details