Tp-link c20 v4.1 help with tftp flashing

i am following the wiki instructions with a linux computer. but the router ends up booting into the factory OEM firmware.
the command:"tcpdump -i eth0 port 69" gives me 11 lines of the same following output.
IP > xyz.tftp: 34 RRQ "tp_recovery.bin" octet timeout 1

am i correct to assume that it means my ip settings are correct, but the tftp server fails?
thank you

you need to set the address to, then send the file using tftp.

i did exactly so.

Have you installed and configured tftp daemon?
You can check correct installation by running tftp client in linux command line.

indeed, i installed tftpd-hpa, copied the tp_recovery.bin file to /var/lib/tftpboot.
i also checked that the file is recognized by the tftp with "get" command.

It should've worked, are you sure the uboot is up and running?
Run this command to find which filename the bootloader is expecting.

sudo tcpdump -npi $interface udp|grep RRQ

You could try with a windows pc
Configure PC with static IP and tftp server (Tftpd).
2. Rename "openwrt-ramips-mt7628-ArcherC20v4-squashfs-tftp-recovery.bin"
to "tp_recovery.bin" and place it in tftp server directory.
3. Connect PC with one of LAN ports, press the reset button, power up
the router and keep button pressed for around 6-7 seconds, until
device starts downloading the file.
4. Router will download file from server, write it to flash and reboot.

or else you may have to force the firmware using serial.

i assume this is the request from the uboot?
IP > 34 RRQ "tp_recovery.bin" octet timeout 1.
i downloaded the file again. also tried to download an older version of the file. same results.

Check linux firewall settings and tftp daemon logs

it was the firewall :slight_smile:
thank you

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.