Tp-link AX23 wrong firmware version number after reverting

I installed stock firmware "Archer AX23(EU)_V1.20_1.1.0 Build 20230725" using procedure described on page:

Why it shows version 3.0.3 after this firmware restore and not 1.1.0?
I asked TP-link support and they told me 3.0.3 is not existing for AX23 v1.2 router...

Do you know why it may happened that the stock firmware 1.1.0 restored on AX23 v1.2 is seen as 3.0.3?

best regards, BB

Because from somewhere it's reading 23.05.3 and dropping the 2 and the 5?

Have you tried installing a full stock firmware with boot from tplink or a full factory reset

1 Like

It is impossible in this state (with this weird firmware verision 3.0.3) to re(install) original firmware from tp-link. The process fails immediatelly when I select .bin and click upload and confirm.

Have you tried all firmware versions?

TP-Link state they have changed the bootloader in the firmware you reference, as you cannot downgrade.

Any updates on this?

Have you tried tplink recovery procedure?
Sometimes tftp, sometimes web upload, but certainly replaces their bootoader.

Sir please help...after reverting stock firmware my firmware version is changed ..

When I am in stock firmware it's 1.1

But now it's showing 3.0.3(5553)

There is no speed control option in this version
:tired_face::tired_face::tired_face::tired_face:please help me please

Likely you need to go via tplink recovery procedure specific for router.

How to go TP-Link recovery procedure ..can U give any link???

It sounds heavy, be very careful to use exact firmware image for hardware.

sir when i follow that mathod..and flash the firmware which i downloaded...after flashing router is not starting...same page load again....

and in this firmware 3.0.3 reset is not working

now what should i do now???

First of all i downloaded a firmware and make it flashable by thos link

then i flashed it in openwrt...then firmware version is changed...

now should i flash this flashable file in tplink recovery???

original file not working in tplink recovery

rename file to short name without spaces and parentheses before uploading to tplink recovery.

Seems you have other source of information, I cannot follow how you got to "converter" tool.

This is original firmware which i am flashing via tp link recovery... but after 100% its load the same page​:sob::sob::sob::sob::sob:

and the file which i made via stock showing its not compatible with this device

Can you post in documentation section to add warning that revert procedure in wiki does not work to add warning there?

I think you can have OpenWRT involuntarily until somebody figures out how to clear version bits on revert.

I have the same issue. I messaged TP Link support and after about 12 back and forth mails, they stopped responding.
If anyone can provide a fix to this, I'd really appreciate that too.

Because of the version issue, Easymesh doesn't work.

does this tplink firmware, before openwrt, have a backup voice, save or restore?

Yes I have a backup of stock firmware .I take it before flashing openwrt..
And when I revert to stock firmware I restore this backup file but nothing happen...and when I revert stock firmware it's showing the setting which I am used before flashing openwrt..
I try to reset the router but reset is not working in this stock firmware

well the bootlog of official firmware is needed here to see if openwrt change something or if is a bug of this official tplink firmware