Tp link. Ax23 debrick?

Yesterday, I updated my TP-Link AX23 v1.2 to OpenWrt SNAPSHOT, version 125603-1a47ce5f12. However, I encountered an issue where I have no internet connection and Luci is not installed. Despite this, I can access my router via SSH and it appears to be functioning properly. My question is: How can I install Luci since the snapshot version does not include it? Alternatively, do I need to reinstall it using TFTP? If so, is it possible to do it without a serial connection?

You have installed a snapshot image. Read the link for instructions how to install Luci, which is not installed by default in snapshots.

https://openwrt.org/faq/can_not_connect_via_webbrowser

1 Like
  • download the 23.05.2 sysupgrade on a separate device
  • scp it to the device
  • sysupgrade from the command line

alternatively

  • download the luci package
  • scp it to the device
  • Install via okg install luci.ipk
<openwrt mirror>/snapshots/targets/ramips/mt7621/packages/

@psherman was faster. :grinning:

1 Like

Usually, I know how to install Luci( with opkg update & opkg install luci but I have no internet at that router ) , but how do I determine which package I need? There are numerous packages and architectures available, so which one should I download?

Simply run opkg install luci, and it'll figure it out.

@xmilenium Why not use the image selector to include LuCI? Easier than trying to cobble together all the packages you need, putting them on a USB stick etc. etc. ...

https://firmware-selector.openwrt.org/

good question, I've always used the rs version and it worked, but yesterday for some reason the internet went down

thanks for advice,it works now :smiley:

p.s and thanks for everyone for their solution sharings :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.