TP-Link Archer MR200 5GHz

I have tried and compiled the 5Ghz wifi for MR200 using files found in the thread https://forum.archive.openwrt.org/viewtopic.php?id=52625&p=1
made modification for my MR200. I used orrangepizza git files https://github.com/orangepizza/openwrt-archer-c2-lede17.01/releases/tag/archer-c2
Basically it is working, but more improvements needs to be done. But now I have a working 5Ghz wifi.

hi @gurangax
can you please share your build ?
if it's not public a PM will do

thanks

Hi,
Here is the link. I'm not sure if default packages like adb is included with this build since my original tplink android modem is broken. I'm using Me909s-120 as the modem.
Currently I am trying to use 16MB flash for this model so can't test it further.

link: http://www.mediafire.com/file/bj3uzeptc3r3sj3/lede-ramips-mt7620-ArcherMR200-squashfs-sysupgrade.zip/file

thanks for the image but it seems it cannot see the default modem (i'm still using)
so i;ve built new 5GHz drivers based on orrangepizza's code for 18.06.1 mr200 image (or any other mt7620 using mt7610e drivers) here https://gofile.io/?c=Pswoy6 (it needs to install fist uci2dat then wireless-tools, then the kmod) . to activate it just do "wifi config", edit the /etc/config/wireless and issue "wifi" - no support for luci unfortunately but the performance is great !

to use the default modem need adb and adb-enablemodem package. I have tried on 18.06.1 but like you said luci is not supported yet (wireless page bug) so I temporarily revert back to Lede. For Lede first need to go to LAN page and click on save/apply.

there is another source https://github.com/Nossiac/mtk-openwrt-feeds if you are interested

no support for mt7610e and for mt7620 i could not enable the 2.4g wifi (some errors in driver)

Last time I tried on openwrt kernel 4.14.67 and his latest .ko is mt7610-for-mt7620-linux-4.14.66.ko. So by default the file is not downloaded and resulted in error. I have to modify the compilation to point to 4.14.66.ko so the file will be downloaded. I forgot how it went after install but there were luci menu for this chip with lots of features to play with.

I have just installed 18.06.4 on to my Tp-link archer MR200 and was wondering if there was any progress on getting 5Ghz wifi working for current releases of openwrt?

There wont be any official release build for the 5Ghz until it is open sourced

i doubt that. driver is available https://github.com/openwrt/mt76
use official links not year or more old forks

Sure unofficial drivers are available, but MR200 has this issue as shown here https://openwrt.org/unsupported/wifi_5ghz , since it is using the MT7610E 5Ghz wifi chip. In other words there is no official drivers available yet and I don't think official support will be available for 5Ghz for now.

BTW I am still using the old unofficial 5Ghz driver for this router.

mt7610e is supported by mt76 for a while now, but it's still a relatively recent addition to mt76, which means not all target profiles (in terms of installing the necessary driver/ firmware, nor taking care of setting it up via DTS or calibration/ MAX setup) know about it yet (because when device support was merged originally, mt7610e wasn't supported, but that has changed meanwhile). This might need some work to actually get it working, but the driver is there and functional (not necessarily top notch, but present and available for improvement).

So does that means FOSS drivers are already available now for mt7610e? If so then that is great news for us. I haven't played with openwrt in a few months now so I'm not sure where we are at, but will try playing with it soon.

kmod-mt76x0e

I have installed kmod-mt76x0e and now have the wireless device Generic MAC80211 802.11bgnac which I have configured correctly to the best of my knowledge in LuCI but I cannot connect to it from any of my 5GHz wifi enabled devices.
Does anyone have any advice on how to set this up to make it work?

I installed kmod-mt76x0e for my Archer C20 V4 but there is no Generic MAC80211 802.11bgnac in Wireless I don't know what to do :roll_eyes:
No one hasn't helped me yet