TP-LINK Archer C7 v5 factory.bin won't load

Hi everyone, newbie here with the first message.

I'm a home user from Istanbul. There is heavy internet censorship(even the Wikipedia is blocked) where I live, and I'm quite into custom firmawares I can setup VPN on. Even though, I'm almost ignorant on computer network structures and have bricked a few routers already(Latest an Archer C7 v4 while updating DD-WRT 2 weeks ago, wrong file apparently...).

I've got a TP-Link Archer C7 v5 now, with the latest stock firmware(c7v5_us-eu-ca-jp-tw-up-ver1-0-4-P1[20180425-rel72768].bin) on it. When I try to upload openwrt firmware I get the error "invalid file type".

I tried everything mention on the topic for the same problem with v2. Except I couldn't find and info on TFTP installation for the v5.

I would appreciate any help on installing openwrt on this device.



I have same problem. Is there a solution?


When I try to install the OpenWrt firmware I got an "Invalid file type" message. This is the firmware what I tried:

Anyone else had this issue before?


Have you tried TFTP method already?


Hi tmomas,

I did not find the tftp steps for v5 anywhere... :frowning:

Should be the same as the others?

Because you didn't click the link in my previous message.

OK, you have to use the install method here:

Do this:;a=commit;h=5bdd238b634a34b038fbea9046893de29a77c000 24 17 but you have to change the filename to ArcherC7v5_tp_recovery.bin

This works.


Thanks, that worked. I could flash trough tftp!

1 Like

i have a C7 V5 and i tried to flash it with TFTP, my filename is ArcherC7v5_tp_recovery.bin and i see the router announce to the ethernet with wineshark but no flash isn't beeing made, any ideas?

Didn't work for me either. Here's the log of my several attempts and a screenshot:

Connection received from on port 1343 [13/10 13:13:23.500]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [13/10 13:13:23.500]
OACK: <timeout=5,> [13/10 13:13:23.500]
Using local port 57883 [13/10 13:13:23.500]
<ArcherC7v5_tp_recovery.bin>: sent 7808 blks, 3997406 bytes in 2 s. 0 blk resent [13/10 13:13:25.196]
Connection received from on port 2099 [13/10 13:14:50.702]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [13/10 13:14:50.703]
OACK: <timeout=5,> [13/10 13:14:50.704]
Using local port 56818 [13/10 13:14:50.704]
<ArcherC7v5_tp_recovery.bin>: sent 7808 blks, 3997406 bytes in 2 s. 0 blk resent [13/10 13:14:52.527]
Connection received from on port 2322 [13/10 13:16:02.781]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [13/10 13:16:02.781]
OACK: <timeout=5,> [13/10 13:16:02.781]
Using local port 50761 [13/10 13:16:02.781]
<ArcherC7v5_tp_recovery.bin>: sent 7808 blks, 3997406 bytes in 2 s. 0 blk resent [13/10 13:16:04.692]
Connection received from on port 1989 [13/10 13:16:14.741]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [13/10 13:16:14.741]
OACK: <timeout=5,> [13/10 13:16:14.741]
Using local port 52952 [13/10 13:16:14.741]
<ArcherC7v5_tp_recovery.bin>: sent 7808 blks, 3997406 bytes in 2 s. 0 blk resent [13/10 13:16:16.443]
Connection received from on port 2114 [13/10 13:16:26.484]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [13/10 13:16:26.484]
OACK: <timeout=5,> [13/10 13:16:26.484]
Using local port 63616 [13/10 13:16:26.484]
<ArcherC7v5_tp_recovery.bin>: sent 7808 blks, 3997406 bytes in 2 s. 0 blk resent [13/10 13:16:28.092]
Connection received from on port 2003 [13/10 13:23:20.930]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [13/10 13:23:20.931]
OACK: <timeout=5,> [13/10 13:23:20.931]
Using local port 59427 [13/10 13:23:20.931]
<ArcherC7v5_tp_recovery.bin>: sent 7808 blks, 3997406 bytes in 2 s. 0 blk resent [13/10 13:23:22.946]


Sorry, my bad! Apparently it installed successfully but I didn't realize without getting back to auto ip on the lan connection. I'm on OpenWrt at this very moment.

Thanks a bunch!

1 Like

At first i was using reset and tftp log was empty. I tried WPS on boot and was the same. I changed PC and keep trying WPS on boot but didnt work till i was able with reset button. So for anyone with tftp not showing anything on logs make sure tftp is running right and use the reset button and not wps

1 Like

I also have this problem (invalid file type). I have a "EU" version, maybe this is the same like the WR841N etc. where you need a EU/US/RU etc. version. Could you check the sticker on the router?

I have the eu version. Make sure tftp client can connect to your tftp server. Also make sure ur holding reset At boot and not wps/WiFi button

1 Like

James, I've got the EU version too. It works fine.


So you could flash it in the webinterface after all? That does not make sense with your other posts.

no, tftp only.

it takes a long time to flash, and a long time to come up. but it will come up.

Not with the latest firmware. When you try to flash OpenWrt bin file you get the error "invalid file type" and it doesn't do anything. I tried to get back to an earlier version of the stock firmware through webinterface and I've got the same error. TFTP worked well though.

do it from linux. use tftpd. do an strace on the tftpd process to find out what filename it is seeking. you Can't do this from web interface, so you will never get a message "invalid file type" from anything.

I'm trying to flash my Archer C7 1750 v5 EU following the steps indicated here, but when the process finish is impossible to acces to router. It only shows the power LED on. If I do the same with the original TP-Link last firmware, the router works again.

I'm using the following firmware: ( ).

I tried with Ubuntu first, and then in Win10, but the result is the same. Can someone help me, please?