TP Link Archer C7 v5 (EU) bricked after update from ver19 to ver21


I was using TP Link Archer C7 v5 with OpenWRT ver 19.
Then I updated some packages via LUCI http. Since then the TP Link Archer C7 V5 (EU) won't boot.
When I power it on all lights are lit for a brief of a second, then all lights but power turn off.

I have tried tftp, but didn't have success.

The TFTP sends the file to the TP LINK ARCHER C7 V5 (EU), then for a while
all lights flash, power button blinks once and power light remains lit. Seems that router doesn't initiate erase and flash the file I send but discards it.

I have tried almost every possible BIN file there is, but couldn't put a life in a router.
Have tried TP-LINK and OPENWRT bin files (TP-LINK stock, Openwrt snapshot, Openwrt upgrade, different versions of Openwrt (18,19,21)).

I have read in forms, that ARCHER C7 V2 checks for HW_ID or Serial_ID and refuses to load if HW_ID isn't matching. I didn't find this numbers in Archer C7 V5. Could this be the same case?

If anyone has been in the same situation and got out of it successfully please advise.

Several threads on the subject -

Solved - successfully flashed new firmware by using TFTP.

I followed this instructions
on this web page (pay attention to SETTINGS in TFTPD64).
Since I have set this settings accodingly (as described in web page) my router accepted new firmware.

On my Archer C7 V5 looked like this.
After holding reset during power for aprox 4sec the light for WDS (2 arrows lit).
After 5 seconds the transfer started - it took aprox 7sec to transfer BIN file.
Then arrows kept on (in previous non successfull attempts, power light blinkt once) lit for aprox 60sec.
Then router rebooted.
When turned on, the Wifi Arrows and UTP LAN port#1 lights flashed.
Router responded with ping and web page.

Link to settings of TFTP server:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.