TP-Link Archer C7 V4 WiFi


I have this up and running, and seem to be able to flash and run v19.07.3 or master, no big issues there. But it seems odd ... wlan0 is 5 GHz, and wlan1 is non-existent? I also try to scan networks for both, and see nothing - so really thinking the WiFi is broken somehow.

Is it really the case that wlan0 is 5 GHz? Or can this be "broken" by the configuration in /etc/config/wireless (i.e. do I need to reset that somehow)? Also, I do see in the kernel log, quite a few lines like the following

[   39.097996] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-5.bin failed with error -2
[   39.109362] ath10k_pci 0000:00:00.0: Falling back to user helper
[   39.206833] firmware ath10k!QCA988X!hw2.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
[   39.216676] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-2.bin failed with error -2
[   39.228030] ath10k_pci 0000:00:00.0: Falling back to user helper



OK, a bit more "playing" with this :rofl:. It does seem that radio0 (wlan0) is 5 GHz, and with some searching and changes to /etc/config/wireless, I do appear to have this radio up - scans work, and in LuCI it shows up as " Qualcomm Atheros QCA9880 802.11acn".

But no joy for radio1 (2.4 GHz). I updated the wireless config as well, based on what seems to work for others (in the forum), but after saving the WPA password from LuCI, the section in /etc/config/wireless gets "minimized" down to,

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option disabled '0'

The device shows up as " Generic 802.11bg", but always shows as not active, and cannot find other devices when scanning ... so I'm really thinking it's not working.

Anyone have any luck with this?


Are you using the ath79 build or the old ar71xx? ath79 should be used.

Delete /etc/config/wireless then reboot to re-generate a file with the correct hardware paths.

1 Like

I think that's likely it - thanks! I was using my old diffconfig, didn't really dawn on me to change it :laughing:

Is it safe to install the ath79 version over top, keep settings (then remove / update wireless like you note above)?

Thanks again.

Hmmm ... that didn't quite do it. It still only auto-finds the 9880 device. Wondering if I need to change something else in .config.


That was it - thanks! I cleared out .config, reset it => now ath79 driver works, both bands. Life is good :rofl:.

One question - is there a reason that radio0 is 5 GHz, radio1 is 2.4 GHz? Just asking as this is the opposite vs. my other routers.

Thanks again

Just the order they get probed on firstboot.

You can change the names in /etc/config/wireless if you want.

1 Like

Wondered if I could just edit the names there - thanks again for the help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.