Tp link archer c7 v2 vlan

i am bit confused with having an interface on eth1.29 vs having an interface on a bridge which has base device eth1.29.

currently i have my switch as: (i think my device doesn't have the DSA architecture yet)

Now i removed (uncofigure) any bridge device here:

And i have added an interface directly onto the VLAN just the way WAN was default configured:

reasoning for me to do this: i want to two vlans which will have two different network.

now when i look at the network file i see the interface has an option as bridge but expection was it would not have a bridge since i directly connected it to switch vlan like the wan was configured:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdcb:26b2:5a86::/48'

config interface 'lan'
	option device 'eth1.29'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option type 'bridge'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 3 4'
	option vid '29'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6t'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '0t 2 5'
	option vid '33'

config interface 'lan33'
	option proto 'static'
	option device 'eth1.33'
	option ipaddr '10.36.33.1'
	option netmask '255.255.255.0'
	option type 'bridge'

can you explain why the option type 'bridge' is set? Chatgpt tells me

In OpenWrt, when you define an interface with a VLAN device (ethX.Y), it automatically creates a bridge interface for that VLAN. This bridge is necessary to connect multiple physical or virtual interfaces together at Layer 2 (the data link layer) of the OSI model.

but if thats true then why in the Devices screenshot there is no bridge device?