TP-Link Archer C7 v2 update

Presently at OpenWrt Chaos Calmer 15.05.1 / LuCI 15.05-149-g0d8bbd2 Release (git-15.363.78009-956be55).
This unit has been working fine for me for a number of years and thought that I should update to newer firmware.
Started looking at what is available and found many posts regarding problems with new firmware. Should I even bother or should I maybe revert back to stock firmware? Bufferbloat improvements were good and I thought I could use QOS but didn't have much success with that.

Well, its only my opinion and we all know how "everybody's got one" but I would recommend staying with OPENWRT unless stock has something that OPENWRT doesn't, which would be a surprise. I'd recommend using a 'current' SYSUPGRADE.BIN for that particular device and flashing it. (using something like WinSCP copy the latest, up to 19.07.7 .bin file to /tmp/fw.bin and then from SSH do 'sysupgrade -v /tmp/fw.bin) <in case you didn't know or just do it from the browser. (Don't click the box to 'SAVE SETTINGS" and do DO a FACTORY RESET afterwards and setup from new (maybe use a printout of the old config) If I had a current and working system under OPENWRT I don't think I'd ever go back to stock, given a choice. Especially given that some companies, LINKSYS, have taken to putting locks in their later firmware to prevent open source, which can lead to all manner of hoops to go through to change back to open... What are you leaning towards? Going back to stock?

I really would like to continue with OPENWRT since it has worked well for me in the past. I am just a bit cautious and don't wish to brick this unit because of wireless problems and needing to reflash numerous times. The wireless has worked for me with the present firmware . Are the drivers used for the latest firmware that much different from my present build? No I probably won't go back to stock.

A few days ago I upgraded my TP-Link Archer C7 v5 to 19.07.7 custom image, just used scp to copy to /tmp and sysupgrade to upgrade. Very easy.

You really need to update. You are running FW that is 6 years old. Would you run a PC on the internet that is running windows ME? That is how out of date you are! Sysupgrade to 19.07.7 don't save settings. BTW it is not qos you want it's SQM.

I realize that an update is necessary. Way overdue!!
I will update and hope that I don't experience the wifi problems some have had.

Updated to OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.044.30835-34e0d65. Did not do factory reset since not sure where this function is found.
5GHZ wifi does not seem to want to turn on but 2.4ghz seems to work ok.

There was a driver switch in 19.07 from ar71xx to ath79 for the Wifi.
You probably need to reset your device, run firstboot via ssh.

If you want the images with the old driver, they're available here -

ar71xx's getting dropped after 19.07, next time you upgrade you'll need to reset the unit anyway.

So reset resets to defaults not to original TP Link firmware?

openwrt defaults.

Did reset but can't seem to get 5ghz working. It comes back saying it is not running and is not associated. I only did system update when I did update. Could there still be a problem with the drivers?

in that case, post your dmesg, after booting.

you might need to do it in

dmesg? How do you do that? Sorry I am not really knowledgeable about these things.

ssh to it, and run dmesg.

or read the kernel log through the webUI.

So do you want a copy of kernel log as viewed in webUI?

whichever is easier for you, should be the same no matter what.

It says the kernel log is too large. How much of it do you need?

that's why you were told to use pastebin.

Sorry have not used pastebin before

then you'll learn something new today.