TP-Link Archer C7 V2: Poor WiFi Performance

I own a TP-Link Archer C7 V2. Using it with the original firmware was not very satisfying as it was constantly disconnecting WiFi connections. I installed LEDE 17.01.4 and this fixed the disconnection problem. I got good WiFi speeds: about 50 Mbps on 2.4 GHz and about 100 Mbps on the 5 GHz. The range was reasonable throughout the house. After a couple of years of trouble free use, the router started disconnecting frequently again, so I upgraded to OpenWRT using openwrt-19.07.3-ath79-generic-tplink_archer-c7-v2-squashfs-sysupgrade.bin

Upgrade went smoothly, and the wifi disconnection problem seemed to be fixed. Now I notice the WiFi range seems poorer and we only get about 50Mbps on the 5 GHz WiFi, even went the device is right next to the router. The 5Ghz WiFi is set AC Mode, auto Channel with Width set to 80GHz. Max transmit power set to driver default.

Any ideas on how to squeeze more speed and range out of the WiFi. I am wondering if this is a driver issue.

Different channels have different max. transmit power. Check your neighbourhood and choose the best compromise and try different antenna angles.

Changing the antenna angles got the speed up to 90 Mbps. Thanks for your suggestion.

echo "[INFO] Switching WiFi firmware from ct to non-ct ..."
opkg remove ath10k-firmware-qca988x-ct kmod-ath10k-ct
opkg install ath10k-firmware-qca988x kmod-ath10k
echo "[INFO] Done. Reboot required."
# reboot

This is what happened:

root@LEDE:~# echo "[INFO] Switching WiFi firmware from ct to non-ct ..."
[INFO] Switching WiFi firmware from ct to non-ct ...
root@LEDE:~# opkg remove ath10k-firmware-qca988x-ct kmod-ath10k-ctopkg remove ath10k-firmware-qca988x-ct kmod-ath10k-ct
Removing package ath10k-firmware-qca988x-ct from root...
Removing package kmod-ath10k-ct from root...
Collected errors:
 * opkg_remove_cmd: Package ath10k-firmware-qca988x-ct is not installed.
root@LEDE:~# opkg install ath10k-firmware-qca988x kmod-ath10k
Unknown package 'ath10k-firmware-qca988x'.
Unknown package 'kmod-ath10k'.
Collected errors:
 * opkg_install_cmd: Cannot install package ath10k-firmware-qca988x.
 * opkg_install_cmd: Cannot install package kmod-ath10k.

I have no 5Ghz signal now. Fortunately 2.4Ghz is still running.

Do I need to ask OpenWRT to download the driver from somewhere?

I am completely new to doing this.

You need to run opkg update first. The run the opkg install command only.

1 Like

sorry, I assumed you were on Openwrr 19.07.3 , I haven't got experience with lede. you can maybe bring the lede drivers back by

opkg update
opkg install (what lede said as removed pkg name after you ran opkg remove above)

I initially upgraded from Firmware to LEDE-17.01.4 and then flashed OpenWRT from within the Backup/Fash Firmware menu, using openwrt-19.07.3-ath79-generic-tplink_archer-c7-v2-squashfs-sysupgrade.

This is what I get when I try to install

Package kmod-ath10k (4.14.180+4.19.120-1-1) installed in root is up to date.
Collected errors:
 * opkg_install_cmd: Cannot install package kmod-ath10kath10k-firmware-qca988x.

I can easily bring back the ath10k-firmware-qca988x-ct kmod-ath10k-ct by reflashing sysupgrade file, but I'd like to get more functional WiFi drivers if I can.

I really have little idea what I'm doing!

Here's the system details:



TP-Link Archer C7 v2


Qualcomm Atheros QCA9558 ver 1 rev 0

Firmware Version

OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.136.49537-fb2f363

Kernel Version


The 5Ghz is working again now. Is there a command that will list the currently used 5Ghz driver?
Thanks for your help in advance.

from the error above I think there was a typo in the PKG name

opkg install ath10k-firmware-qca988x

this works on mine after opkg update

Thanks CatFriend1, I think that did it. Saves buying a new router :slight_smile:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I had a similar problem with my TP-Link Archer C7 and Openwrt 19.07.3. CatFriend1 instructions fixed it.
Mine was worse as 5 GHz would not even start without the recommended change in package.
Is there a bug report for this ?

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.