TP-Link Archer C7 v2 OpenWRT 18.06.4 Wi-Fi client problem - sites do not load

Today I met some mystery while clienting Wi-Fi. My configuration is: another router (Asus RT-AC68U) is connected to my ISP with a cable, and that router also shares Wi-Fi 2.4 GHz, let's call it "asus_wifi". I connect to it with my tablet, and all is well: I can open all sites. Now I connect my Archer C7 as a client to "asus_wifi" through "Scan" option on "Wireless" page. It connects successfully, shows signal level. Archer C7 is cable connected to my comp, and when I try to connect through it to the Internet, most sites do not open. Firefox shows "Waiting for..." or "Making a TLS handshake with..." and does not load further. I can open or, but those are exceptions.

"Traceroute" works well - on "Diagnostics" page and in comp console.

I tried to play with DNSes: put in LAN settings and in "DHCP and DNS", but with no progress on the problem. Maybe the solution is simple, but I cannot find it by myself. Please help.

Most likely MTU issue.

1 Like

Yes, thanks! Thas was it. I overrode MTU with "1300", and everything works now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.