TP Link Archer C7 v2 - OpenWrt 18.06.1 r7258-5eb055306f - Hw related bug?

HI, I have successfully configured and flashed my router with this firmware. Everything seems to be working great except I have some peeves. Hope someone could enlightened me if I may have missed any details out.

Peeves (Issues)
1.I can connect to the 802.11ac AP with my phone. However, everytime I do a speedtest ( or The whole router will reboot itself. Any idea what this is about?

  1. My VLAN switch page shows that I am connected at 100mbps instead of 1000 mbps. Am using a CAT5e cable and the port is known to be working fine at 1000mbps levels (Modem and Cable support). eth0 & eth1 and WAN shows 1000mbps (with necessary cat 5e cables) but the individual ports doesnt connect at that speed(only 100mbps). My ISP requires some specific VLAN settings (VLAN 500 for WAN, VLAN600 for IPTV) hence could that networking config be the issue?

My ISP gives me 500mbps and I have managed to get 370 mbps using another router(With only 1 vlan set) and desktop. However, testing on this router via CLI I got maximum 90mbps from WAN.

I've your tried the same config but using LEDE 17.01.6 found here:

I've been using 18.06.1 for a short time, but I had some problems (disconnections, some kernel warnings..) I went to 17.01.XX and now is working fine.

Also take a look here: Ath79 builds with all kmod packages through opkg [flow offloading]

It seems to be working fine in Archer C7 v2, but I haven't tested it.

I found out my problem. Firmware is working great. My problem came from using a 5v adapter with 2a. I only had another 12v 0.6a adapter at my disposal and once I switched to that both problems went away. In short, not a firmware problem.

Now that probably need to get a new adapter with sufficient Amp then all is perfect.

1 Like

I'm surprised it worked at all at 5 V! I find that a 12 V, 1 A adapter is sufficient for an Archer C7 v2 that isn't driving any USB devices. 0.6 A is probably a little tight as the device draws just under 400 mA (0.4 A) at 12 V, running the radios as a "dumb AP" and no NAT.