TP-link archer C7 V2 bricked

hello everyone I am new to the tech forums and I’m hopping that someone might be will to give me a few mins of there time. I have a TP-Link Archer C7 V2 USA. I wanted to install the open WRT firmware on it. I started off by reading some pointers on the web and did see that V1, V2 and V2.1 are all a pain when it comes to upgrading to open-wrt. That said I downloaded the firmware from this site for my router and went ahead on trying to web flash it with my iPhone, the file wouldn’t originally take so I tried it again. After taking some time to really read what was posted on this site I realized that I had actually dodged a bullet because had it tried to download I would have bricked my router with out changing the necessary packages in the firmware. Well I stayed persistent and managed to brick my router. “Lesson learned” don’t get mad and say whatever when it comes to loading firmware into a computer board. To help this story/question along I ended up being able to use my laptop and setup a Tftp file server and get the router out of the bricked state. Now before I had tried the tftp method I downloaded the stock tp-link firmware and that is what I had the tftp server serve to the router. The lights came back on and the router booted up. This gets a little nuts here, when I plugged into via LAN the router had a working version of open-wrt wtf!… probably just dumb luck. Anyways I figured that I would tempt fait and try to reload the factory TP link firmware. When I tried to push the firmware through the router wouldn’t take it. So being an Idiot I tried again this time it appeared to have gone through the factory firmware that is….wrong something was pushed into the router but it’s not the factory TP link firmware now my router is stuck in a boot loop. Everything I could find says I need to change the Auth something or other file in program I just have no idea how to do this. Would anyone have a link to firmware that I could down load and try to re-flash my router. Oh and I forgot some details I ended up making a serial cable following what I read online but I can’t seem to get the boot loop to stop no matter what I press on the keyboard. From what I read this is a really common issue with to link archer c7 v2. Somebody, anybody help please I do t want to give up on it I love Messing with the networking stuff I’m super new to it but love. Any help is greatly appreciated

TLDR, no new lines.

try the TFTP recovery, and files from

It could be useful to actually copy & paste the error messages you have or log the console output you see on serial. Also making chronological references to firmware files/download URL's you have used may give us more insight where progress stalled. For instance what was the Tp-link software version you started from or which Openwrt Release 21.x / 22.x /snapshots or even which Architecture: ar71xx/ath79 did you flash? Using the markdown/styling code in this forum to 'quote' these messages in readable blocks might also improve communication.

Having flashed multiple of these v2 devices from different origins I haven't noticed any of these issues.

U-Boot 1.1.4 (Jan 14 2018 - 10:37:14)

ap135 - Scorpion 1.0DRAM:
Scorpion 1.0
ath_ddr_initial_config(179): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x4, 0x1f)
Tap values = (0x11, 0x11, 0x11, 0x11)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment

*** Warning *** : PCIe WLAN Module not found !!!
In:    serial
Out:   serial
Err:   serial
Net:   ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x6
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion  ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00014001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:ce:08:xx
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:ce:08:xx
eth1 up
eth0, eth1
Setting 0x18116290 to 0x58b1214f
eth1 link down
eth0 link down
Using eth1 device
TFTP from server; our IP address is
Filename 'ArcherC7v2_tp_recovery.bin'.
Load address: 0x80060000
Loading: T T ## Booting image at 9f020000 ...
   Uncompressing Kernel Image ...image too big

So here’s what the serial output is showing me on putty for this death boot loop, if I would have left well enough alone. Sorry I’m pretty new to the computer hardware software tinkering I’m a buildings automation/energy management working with micro controllers and basic logic so I know enough to know that I don’t know s&@!. Haha anyways I’ll definitely do better recording what I do next time it’s probably no help but if my first post made any sense, I had the latest tp link archer c7 v2 firmware then went to openwrt. I used the tool they have with all the different router manufacturers to find my router and hardware version then downloaded the latest openwrt firmware, that wouldn’t take to the router it kept saying wrong file or something to that affect. Then I bricked it so that’s when I found the tftp server recovery, I plugged my router into my laptop cat6 then ran my solar winds tftp @ or 69 downloaded wire shark and could see the routers response to the tftp call at first I couldn’t get the firmware to load then changed the name convention to the archer_c7_v2-tp-recover.bin that worked and I had the newest version to my knowledge of openwrt. That’s when I had my stole of Genius and decided I wanted the stock tp link firmware for the print server or something stupid and tried to reload the factory tp link archer c7 v2 firmware download from tp link yes, the us version as it’s region sensitive. When I tried pushing it through via openwrt through the router interface it wouldn’t expect the factory tp link firmware so hey why not force it right, not. I used the tftp method and pushed the tp link firmware again and the router started to take it then shit the bed. Now it’s stuck in the boot loop I attached a pic. When looking for help I found a ton of people with that same serial output. I had seen a viedo with another tp link router where the guy says to hold control when you power up the router and that should interrupt that boot loop and give access to a command line bash type terminal mode but I tried and I can’t stop the dam boot loop, if I pull the ground pin on the serial connection off the router circuit board it keeps going on the serial output but it’s all jumbled and gibberish until I reconnect the ground pin. Anyone ever herd of something like short RX to TX to change the “serial mode” or is that just some internet nonsense. Any helps really appreciated sorry for being that guy, ha.

Recover using the TFTP server method. Written for Windows users...but the concepts are the same for other OS.

Download the stock may need to try more than one version.


The OpenWRT "factory" firmware can also be used if you don't want to go back to stock.

Download TFTP64.

Rename the downloaded firmware file to ArcherC7v2_tp_recovery.bin, and place it in the same folder as TFTPD64.

Open your network settings in Windows, and select the wired adapter (don't try this on a wireless connection).

Note: It's a good idea to use an unmanaged switch between the router and the computer. It avoids the link-down event, and link training.

Right-click and select Properties.

Select Internet Protocol Version 4 (TCP/IPv4) and click on the Properties button.

In the General tab, select the radio button for Use the Following IP Address.

Enter for the IP address.

Should default to for the Subnet Mask.

Turn the router off.

Make sure nothing else is connected to the router, it should be just the router and your computer.

Open TFTPD64. You may be asked to allow it through the firewall. Select Public.

Note: You may need to temporarily disable the firewall.

Go to Settings > Global, and uncheck everything except TFTP Server.

Go to Settings > TFTP. Select None for TFTP security. Uncheck Option negotiation, and enter in the Bind to this IP address drop down.

Go back to the main window, and make sure the Current Directory dropdown is showing the path to the TFTPD64 folder, which should also contain your recovery firmware file ArcherC7v2_tp_recovery.bin

The IP address should be displayed in the Server Interface dropdown. If not, select it.

Go to the router and press the power button and the reset button at the same time.

Release the power button...but continue to hold the reset button for about 4 or 5 seconds, then release.

You should see a progress bar going across the TFTPD64 screen (although it should only take a very short time).

View the log. It should show 100% transferred.

Go back to your wired network adapter, and change the radio button back to Obtain an IP Address Automatically.

Try to access the router GUI. The stock firmware IP address is and admin/admin for the User Id and Password.

If you can see that you have Internet access in the Network icon, but can't access the GUI, open a Command prompt and run ipconfig /release and then ipconfig /renew.

Try to access the GUI again.

1 Like

Architecture, you may try OpenWrt 19.07.x ar71xx factory instead of the newer ath79?