Tp-link Archer C7 v2.0 upgrade from OWrt

#1

Hello all,

I am an OpenWrt user on a TP-Link Archer C7 v2.0. I am having issues with Wifi in my home as I live in a crouded area. It's not uncommon when scanning for WiFi signal to get ~30+ networks. Of course not all of them are strong enough but I guess they interfear.

My question is this. My version of OpenWrt is 15.05.1, r48532 which is as I understand the latest stable. I am interesting in the ath10k patches that were added after March 2016 so this is why I'm looking on LEDE as I am hoping to have smaller release cycles than OWrt. So have anyone installed LEDE on Archer C7 v2.0 successfully? What's the process to "upgrade" from OpenWrt? As there are no releases yet do we all get master branch and how stable is that?

I'm asking because the router is supporting my only internet connection at home and wouldn't like to stay without one for longer than I need to install a new Firmware (couple of hours?)

Apologies if these have been asked before. I hope this fresh project will help in quicker releases and better support for issues instead of wasting time in discussions. :slight_smile:

Thanks in advance

0 Likes

#2

Hello @artafinde Welcome to LEDE

You're asking all the right questions. Most important first:

  • If your router is the only router you have, and you're relying on it for service, then you are correct to ask how stable LEDE is. To date, there has not been a stable release.

  • That said, the current builds have been quite stable for the folks who're using them, and are unlikely to cause a problem. However, there is always a chance that the current development snapshot will introduce a bug.

  • The Archer C7v2 is in the sweet spot. It's reliable hardware that is well supported both by LEDE and OpenWrt.

  • In fact, Toke has been building LEDE with GUI, the wi-fi fixes, and most of the packages you would ever need for several router models, including the Archer C7 v2. They're at https://kau.toke.dk/lede/airtime-fairness-builds/ar71xx/generic/ These receive some testing, so they would probably be safe to install. (I helped a friend install this on his Archer C7)

  • And if you're already running OpenWrt on the router, you won't have to farble around with the TP-Link workaround. (The workaround requires you to install an OpenWrt DD image (any recent image) onto the router, then install the desired LEDE.) But you're not affected, since you already installed OpenWrt...

  • Lastly: read the Quick Start Guide to learn how to get LEDE installed on the router, and...

  • ... Read the Standard Flashing Instructions to learn how to flash the sysupgrade firmware for your router.

TL;DR If you are risk-averse, stay with your current (15.05.1) firmware. If you want to try out LEDE/the new wifi airtime fairness code, try Toke's build.

Feel free to ask more questions as they arise.

0 Likes

#3

Hi @richb-hanover

Thanks for your detailed answer. It looks like you understood my worries and answered precisely.

Having said that though I installed last night OWrt snapshot (nightly) and spend about 1-2 hours installing my packages. Seems like there's an issue with uhttpd daemon script spamming the logs so I disabled the web UI (irrelevant for this forum). I'll need to doesn't some time testing the WiFi to see if the new ath10k firmware fixed anything, it certainly has more information on the web UI page about the status of the 5G WiFi and the devices connected.

Coming back to lede subject, the builds with the WiFi packages seems very interesting. Is there a forum thread I can find more information about the Toke builds?

I'm also willing to build my own lede package if I get the .config and start tweaking it, I'm a fairly standard user of vagrant so I'll focus on making lede build with it (dev guide include one)

Thanks again

0 Likes

#4

A small update on this

I tried the suggested image and didn't "keep settings" as recommended from the docs. I was surprised to find out the image didn't have PPPoE support so my router couldn't do something as without it I couldn't connect o the internet to download it. I'm back to OWrt for now until I found how to build my own image and put what I need in there.

I'll be taking a look at the vagrant build (in dev docs) but it seems like it can be maintained a bit more.

Thanks

0 Likes

#5

Hmmm... I'm surprised as well that there wasn't pppoe support.

You can check out the mailing list at https://lists.bufferbloat.net/pipermail/make-wifi-fast/2016-November/001140.html

0 Likes

#6

Took the plunge on my own C7 with toke's build. Thanks for the great suggestion - completely seamless build,

0 Likes

#7

Any input on the performance? Is it an improvement over the OpenWRT build?

Thanks!

0 Likes

#8

Seems to work ... for the moment, but default Setup should be improved (e.g. default Wireless Channel Setup for EU, US, IL... )

Files from Toke´s Build´s can´t be used directly because of long Filenames that containing a + (plus) inside (flashed from latest factory) - rename the long one into "factory-eu.bin" worked for me.

Total time to flash / setup the router: ~ 3 Minutes (it was not my first time)

http://www.dslreports.com/speedtest/7663554
Note: Speedtest SQM QoS enabled (50/2.5)

0 Likes

#9

For me Toke's builds are a no-go as they don't have out of the box support for PPPoE. People suggested I use another router to set-it up and install PPPoE later which would work but I don't have another router. So I'm currently using LEDE snapshot.

I'm eagerly waiting for the release of LEDE and I have tracked down my steps for configuration so I can repopulate all my config and install packages through script.

0 Likes

#10

Right... as a user behind a cable Router I don´t have to fight with that!

It would be great to have a basic Setup - just usable for everyone! For example WiFi / Country + SQM QoS Setup for the right interface etc....

Let´s make LEDE great! :wink:

0 Likes

#11

So, I ended up rolling back for 2 reasons...

I run a dual-router setup (my house is VERY rectangular, and my easiest entry points are at both long ends), 1 AP/router and 1 AP/switch.

  1. The annoyances with ath10k and getting ac to work seem to have come over from openwrt. I thought this would have been squashed in openwrt long ago, but it seems to persist. 149 and VHT80 seemed to work on one router, but i can't run that on both, and the second router was a nightmare to get up and running.

  2. Can't see why, but this build dropped my wired throughput from the 2nd router to 6Mbps. I rolled back to gargoyle on the main router, and everything worked great.

0 Likes