TP-Link Archer C7(US) v5 reflashing ISPs openwrt

Hi, I received from my ISP a TP-Link Archer C7(US) v5 as a gift for 3 years. It has has openwrt installed.

It is locked so I can't login and anyway I don't like what they did and would like to flash it by myself.

tftp check

john@laptop:~$ ls /var/tftpboot -la

total 16156

drwxrwxrwx 2 nobody root 4096 Jan 13 14:58 .

drwxr-xr-x 15 root root 4096 Jan 13 05:51 ..

-rw-rw-r-- 1 john john 4194481 Jan 13 09:21 ArcherC7v5_tp_recovery.bin

-rwxrwxrwx 1 nobody john 3 Jan 13 08:13 a.txt

-rw-rw-r-- 1 john john 4194481 Jan 13 09:21 tp_recovery.bin

-rw-r--r-- 1 john john 8126464 Jan 13 09:25 wdr4300v1_tp_recovery.bin

john@laptop:~$ tftp

tftp> get tp_recovery.bin

Received 4225721 bytes in 0.1 seconds

tftp> get ArcherC7v5_tp_recovery.bin

Received 4225721 bytes in 0.1 seconds

tftp> q


Did power off. After few seconds, pressed Reset and without releasing pressed power. Released Reset after 20-25 seconds.

Nothing worked. Tried both files:



to put into the root of tftp as a pair ArcherC7v5_tp_recovery.bin & tp_recovery.bin

I connected using serial to that device and nothing looks like it attempts to flash itself from tftp.

Initially had issues with pinouts. Ground identify was easy, then I mesured voltage and 1 pin was 2.9V other had some mV. So I

thought that the one which has 2.9V is 3.3v which is the first. 2nd pin was ground. When I connected just 4th pin I saw output in the Putty(for Ubuntu). So, I believe they go 1th-3.3V, 2nd-GND, 3rd-RX, 4th-TX. Once again I saw out when I had

1 - GND

2 - RX from CP201x

I see in the output it asks

Setting 0x181162c0 to 0x41822100

Hit any key to stop autoboot: 0

## Booting image at 9f0c0000 ...

Tried to press any keys no luck. I also copied "tpl" into clipboard. After the start once this "Hit any key to stop autoboot" appears I pressed quickly Ctrl+V few times. Also tried press it many times from the start nothing worked.

I did a loopback test for CP201x, by shorting TX & RX and I saw in the terminal symbols I have typed. I also soldered again a 3rd pin suspecting that I have not soldered it well.

I was connected using normal(normally used to connect pc to switch/router) 5 meters ethernet cable from my laptop to the first LAN port.

What did I do wrong what else should I try?

:+1::+1::+1: on all the efforts and steps youve gone through to fix the problem on your own.

Two possibilities i can think of

  1. The pin you think is for tx might actually be something else. See if there is any other pads it might be.
  2. Given they already put openwrt on their themselves, it could be that they have disabled serial tx connection somehow.
  3. If your using a usb-ttl cable, try this
  • disconnecting it the usb-ttl from the pc (the usb end)
  • power off the router
  • connect usb-ttl to your pc again
  • start whatever serial terminal softeware your using
  • then power on the device

My usb-ttl cable misses some output from the bootloader unless i follow the above. So i presume some of the inputs/keystrokes i enter are also not getting through.

Thanks, the answer is here Archer C7(RU) V5 install throught UART. and the next one I posted is quite important.
This one I think needs to be closed.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.