TP-Link Archer C7 AC1750 V2 5GHz issue

Hi Wifi experts,

I can't get my 5GHz wifi to work, here are some configurations:

 root@LEDE:~# iw reg get
 global
 country DE: DFS-ETSI
 	(2400 - 2483 @ 40), (N/A, 20), (N/A)
 	(5150 - 5250 @ 80), (N/A, 20), (N/A), NO-OUTDOOR, AUTO-BW
 	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
 	(5470 - 5725 @ 160), (N/A, 27), (0 ms), DFS
 	(5725 - 5875 @ 80), (N/A, 14), (N/A)
 	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

 phy#1
 country US: DFS-FCC
 	(2402 - 2472 @ 40), (N/A, 30), (N/A)
 	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
 	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
 	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
 	(5735 - 5835 @ 80), (N/A, 30), (N/A)
 	(57240 - 63720 @ 2160), (N/A, 40), (N/A)

 phy#0
 country US: DFS-FCC
 	(2402 - 2472 @ 40), (N/A, 30), (N/A)
 	(5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
 	(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
 	(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
 	(5735 - 5835 @ 80), (N/A, 30), (N/A)
 	(57240 - 63720 @ 2160), (N/A, 40), (N/A)
 root@LEDE:~# iw phy0 info
 Wiphy phy0
 	max # scan SSIDs: 16
 	max scan IEs length: 199 bytes
 	max # sched scan SSIDs: 0
 	max # match sets: 0
 	max # scan plans: 1
 	max scan plan interval: -1
 	max scan plan iterations: 0
 	Retry short limit: 7
 	Retry long limit: 4
 	Coverage class: 1 (up to 450m)
 	Device supports AP-side u-APSD.
 	Available Antennas: TX 0x7 RX 0x7
 	Configured Antennas: TX 0x7 RX 0x7
 	Supported interface modes:
 		 * managed
 		 * AP
 		 * AP/VLAN
 		 * monitor
 		 * mesh point
 	Band 2:
 		Capabilities: 0x19ef
 			RX LDPC
 			HT20/HT40
 			SM Power Save disabled
 			RX HT20 SGI
 			RX HT40 SGI
 			TX STBC
 			RX STBC 1-stream
 			Max AMSDU length: 7935 bytes
 			DSSS/CCK HT40
 		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
 		Minimum RX AMPDU time spacing: 8 usec (0x06)
 		HT TX/RX MCS rate indexes supported: 0-23
 		VHT Capabilities (0x338001b2):
 			Max MPDU length: 11454
 			Supported Channel Width: neither 160 nor 80+80
 			RX LDPC
                         short GI (80 MHz)
 			TX STBC
 			RX antenna pattern consistency
 			TX antenna pattern consistency
 		VHT RX MCS set:
 			1 streams: MCS 0-9
 			2 streams: MCS 0-9
 			3 streams: MCS 0-9
 			4 streams: not supported
 			5 streams: not supported
 			6 streams: not supported
 			7 streams: not supported
 			8 streams: not supported
 		VHT RX highest supported: 0 Mbps
 		VHT TX MCS set:
 			1 streams: MCS 0-9
 			2 streams: MCS 0-9
 			3 streams: MCS 0-9
 			4 streams: not supported
 			5 streams: not supported
 			6 streams: not supported
 			7 streams: not supported
 			8 streams: not supported
 		VHT TX highest supported: 0 Mbps
 		Frequencies:
                         * 5180 MHz [36] (20.0 dBm)
 			* 5200 MHz [40] (20.0 dBm)
 			* 5220 MHz [44] (20.0 dBm)
 			* 5240 MHz [48] (20.0 dBm)
 			* 5260 MHz [52] (20.0 dBm) (radar detection)
 			* 5280 MHz [56] (20.0 dBm) (radar detection)
 			* 5300 MHz [60] (20.0 dBm) (radar detection)
 			* 5320 MHz [64] (20.0 dBm) (radar detection)
 			* 5500 MHz [100] (27.0 dBm) (radar detection)
 			* 5520 MHz [104] (27.0 dBm) (radar detection)
 			* 5540 MHz [108] (27.0 dBm) (radar detection)
 			* 5560 MHz [112] (27.0 dBm) (radar detection)
 			* 5580 MHz [116] (27.0 dBm) (radar detection)
 			* 5600 MHz [120] (27.0 dBm) (radar detection)
 			* 5620 MHz [124] (27.0 dBm) (radar detection)
 			* 5640 MHz [128] (27.0 dBm) (radar detection)
 			* 5660 MHz [132] (27.0 dBm) (radar detection)
 			* 5680 MHz [136] (27.0 dBm) (radar detection)
 			* 5700 MHz [140] (27.0 dBm) (radar detection)
 			* 5720 MHz [144] (disabled)
 			* 5745 MHz [149] (14.0 dBm)
 			* 5765 MHz [153] (14.0 dBm)
 			* 5785 MHz [157] (14.0 dBm)
 			* 5805 MHz [161] (14.0 dBm)
 			* 5825 MHz [165] (14.0 dBm)
 			* 5845 MHz [169] (14.0 dBm)
 	valid interface combinations:
 		 * #{ AP, mesh point } <= 8, #{ managed } <= 1,
 		   total <= 8, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

 	HT Capability overrides:
 		 * MCS: ff ff ff ff ff ff ff ff ff ff
 		 * maximum A-MSDU length
 		 * supported channel width
 		 * short GI for 40 MHz
 		 * max A-MPDU length exponent
 		 * min MPDU start spacing
 	Device supports VHT-IBSS.
 root@LEDE:~# iw phy1 info 
 Wiphy phy1
 	max # scan SSIDs: 4
 	max scan IEs length: 2257 bytes
 	max # sched scan SSIDs: 0
 	max # match sets: 0
 	max # scan plans: 1
 	max scan plan interval: -1
 	max scan plan iterations: 0
 	Retry short limit: 7
 	Retry long limit: 4
 	Coverage class: 1 (up to 450m)
 	Device supports AP-side u-APSD.
 	Device supports T-DLS.
 	Available Antennas: TX 0x7 RX 0x7
 	Configured Antennas: TX 0x7 RX 0x7
 	Supported interface modes:
 		 * IBSS
 		 * managed
 		 * AP
 		 * AP/VLAN
 		 * monitor
 		 * mesh point
 		 * P2P-client
 		 * P2P-GO
 		 * outside context of a BSS
 	Band 1:
 		Capabilities: 0x11ef
 			RX LDPC
 			HT20/HT40
 			SM Power Save disabled
 			RX HT20 SGI
 			RX HT40 SGI
 			TX STBC
 			RX STBC 1-stream
 			Max AMSDU length: 3839 bytes
 			DSSS/CCK HT40
 		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
 		Minimum RX AMPDU time spacing: 8 usec (0x06)
 		HT TX/RX MCS rate indexes supported: 0-23
 		Frequencies:
                         * 2412 MHz [1] (20.0 dBm)
 			* 2417 MHz [2] (20.0 dBm)
 			* 2422 MHz [3] (20.0 dBm)
 			* 2427 MHz [4] (20.0 dBm)
 			* 2432 MHz [5] (20.0 dBm)
 			* 2437 MHz [6] (20.0 dBm)
 			* 2442 MHz [7] (20.0 dBm)
 			* 2447 MHz [8] (20.0 dBm)
 			* 2452 MHz [9] (20.0 dBm)
 			* 2457 MHz [10] (20.0 dBm)
 			* 2462 MHz [11] (20.0 dBm)
 			* 2467 MHz [12] (20.0 dBm)
 			* 2472 MHz [13] (20.0 dBm)
 			* 2484 MHz [14] (disabled)
 	valid interface combinations:
 		 * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
 		   total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

 	HT Capability overrides:
 		 * MCS: ff ff ff ff ff ff ff ff ff ff
 		 * maximum A-MSDU length
 		 * supported channel width
 		 * short GI for 40 MHz
 		 * max A-MPDU length exponent
 		 * min MPDU start spacing
 root@LEDE:~# cat /etc/config/wireless 

 config wifi-device 'radio0'
 	option type 'mac80211'
 	option hwmode '11a'
 	option path 'pci0000:01/0000:01:00.0'
 	option distance '15'
 	option country 'DE'
 	option htmode 'VHT80'
 	option channel '36'

 config wifi-iface 'default_radio0'
 	option device 'radio0'
 	option mode 'ap'
 	option key 'secret'
 	option encryption 'psk2'
 	option ssid 'LEDE_5G'
 	option network 'wlan'

 config wifi-device 'radio1'
 	option type 'mac80211'
 	option channel '11'
 	option hwmode '11g'
 	option path 'platform/qca955x_wmac'
 	option htmode 'HT20'
 	option country 'DE'
 	option distance '15'
 	option disabled '0'

 config wifi-iface 'default_radio1'
 	option device 'radio1'
 	option mode 'ap'
 	option ssid 'LEDE'
 	option key 'secret'
 	option encryption 'psk2'
 	option network 'wlan'

 rroot@LEDE:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd89:aa53:7095::/48'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '10.0.10.1'
	option gateway '10.0.10.1'
	option broadcast '10.0.10.255'
	option _orig_ifname 'eth1'
	option _orig_bridge 'true'
	option type 'bridge'
	option ifname 'eth0 eth0.1'

config interface 'wan'
	option proto 'dhcp'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option ifname 'eth1'

config interface 'wan6'
	option proto 'dhcpv6'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option ifname 'eth1'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0 1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '2 3 4 5 6t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '6t'
	
config interface 'wlan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.0.30.1'
	option gateway '10.0.30.1'
	option broadcast '10.0.30.255'
	option _orig_ifname 'eth0.3 radio1.network1'
	option _orig_bridge 'true'
	option ifname 'eth0 eth0.3'

root@LEDE:~# logread -f
Sun Apr 30 11:46:55 2017 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Sun Apr 30 11:46:58 2017 kern.info kernel: [ 2775.686605] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sun Apr 30 11:46:58 2017 daemon.notice hostapd: wlan0: INTERFACE-ENABLED
Sun Apr 30 11:46:58 2017 daemon.notice hostapd: wlan0: INTERFACE-DISABLED
Sun Apr 30 11:46:58 2017 daemon.err hostapd: nl80211: Could not configure driver mode
Sun Apr 30 11:46:58 2017 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Sun Apr 30 11:46:58 2017 daemon.err hostapd: nl80211 driver initialization failed.
Sun Apr 30 11:46:58 2017 daemon.notice hostapd: wlan0: interface state UNINITIALIZED-DISABLED
Sun Apr 30 11:46:58 2017 daemon.notice hostapd: wlan0: AP-DISABLED
Sun Apr 30 11:46:58 2017 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Sun Apr 30 11:46:58 2017 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Sun Apr 30 11:46:58 2017 daemon.notice netifd: radio0 (21482): Device setup failed: HOSTAPD_START_FAILED
Sun Apr 30 11:46:59 2017 daemon.info odhcpd[828]: Using a RA lifetime of 1800 seconds on eth0
Sun Apr 30 11:47:19 2017 daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
Sun Apr 30 11:47:21 2017 kern.info kernel: [ 2798.890486] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Sun Apr 30 11:47:21 2017 daemon.notice hostapd: wlan0: INTERFACE-ENABLED
Sun Apr 30 11:47:21 2017 daemon.notice hostapd: wlan0: INTERFACE-DISABLED
Sun Apr 30 11:47:21 2017 daemon.err hostapd: nl80211: Could not configure driver mode
Sun Apr 30 11:47:21 2017 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Sun Apr 30 11:47:21 2017 daemon.err hostapd: nl80211 driver initialization failed.
Sun Apr 30 11:47:21 2017 daemon.notice hostapd: wlan0: interface state UNINITIALIZED-DISABLED
Sun Apr 30 11:47:21 2017 daemon.notice hostapd: wlan0: AP-DISABLED
Sun Apr 30 11:47:21 2017 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Sun Apr 30 11:47:21 2017 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Sun Apr 30 11:47:21 2017 daemon.notice netifd: radio0 (22084): Device setup failed: HOSTAPD_START_FAILED
Sun Apr 30 11:47:22 2017 daemon.info odhcpd[828]: Using a RA lifetime of 1800 seconds on eth0
Sun Apr 30 11:47:26 2017 daemon.info odhcpd[828]: Raising SIGUSR1 due to address change on eth0
Sun Apr 30 11:47:27 2017 daemon.info odhcpd[828]: Using a RA lifetime of 1800 seconds on eth0
Sun Apr 30 11:47:56 2017 daemon.info odhcpd[828]: Raising SIGUSR1 due to address change on eth1
Sun Apr 30 11:47:56 2017 daemon.info odhcpd[828]: Raising SIGUSR1 due to address change on eth0
Sun Apr 30 11:47:57 2017 daemon.info odhcpd[828]: Using a RA lifetime of 1800 seconds on eth0

I appreciate your help.

Thanks a lot!

After checking several channels I made it work. Thanks