TP Link Archer C7 AC1750 Bricked

Hi. I accidentally used the Web GUI to restore my TP Link Archer C7 AC1750 v5 back to stock firmware. But unfortunately, the router stopped working. Only power led light is on. I tried to restore it using TFTP but it doesn't work. When I press the reset button, double arrow will light on but will off after few seconds. Nothing is happening in TFTP server. I hope you can give me some suggestions or tips how to fix this. Thank you.

Hopefully a TFTP recovery still will work in your case..

Did you follow the process listed in the TFTP recovery section of the device info page and the additional directions here?

Keep in mind that it can be confusing sometimes -- our intuitive feeling with these devices is that we must put/push the firmware file to the router. This is not the case with this device (among many others). Here you will set your computer to host the file, but the router will actually pull it from the server automatically when TFTP recovery mode is engaged on the router.

Can you describe the specific steps you took when you tried the TFTP recovery?

1 Like

These are the steps that I followed.

  1. Open the TFTP Server (Tftpd64). IP set to
  2. Browse for firmware directory
  3. Press the reset button of the router then turn it on until WPS light is on.

Then nothing happened.

Did you download the "factory" image or the sysupgrade version? Did you rename the file properly ArcherC7v2_tp_recovery.bin?

sniff the wire to see if the device is actually making a request.


The problem is nothing seems happening. No error in TFTP Server. Yes, I renamed the file.

Finally, I used external LAN CARD. Thank you for the replies everyone.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.