TP-Link Archer C7 2.4ghz wifi dropout

I've been having occasional wifi radio problems, on the above device. The 2.4ghz radio in the C7 will become non responsive, and a restart of the radio, or rebooting of the whole router will get it working again. This has been happening on 18.06.04 and a few snapshots, seen it a few times on the currently running 19.07.0-rc2.

I used to get 5ghz radio issues, as well, but in recent tines its all been the 2.4 radio. Nothing much noticable in logs, have many recorded. Got a clue recently, after installing luci-app-statistics. I saw the RX traffic go to 0, while the TX traffic was still there. RX shut down somehow? Still, nothing in the syslog, unless I'm missing it. Any suggestions on how to troubleshoot?

1 Like

I see currently the same issue, using my owned compiled snapshot, the same on 19.07.0-rc2. Nothing in the logs, just all 2.4 clients are disconnected and are not connecting anymore. Wifi down && Wifi up solve this for few hours. I'm even rebooting router each day. It's very annoying.

Does searching the forum for Archer C7 wifi yield something usefull?

You mean that more threads mention that ? Well, yes...but don't see any solution nor diagnostic data we shall be providing eventually. Also for me it's happening several times per day, already using script for workaround but it's also not working for ever and have to reboot AP more times per day.

Bringing this back, maybe I've stumbled across a clue.

Was reading another thread about running out of sirq. They mentioned that they were having difficulty getting higher than 300-400mbit with the 5ghz ac radio, apparently due to the cpu saturated with 99% sirq. See : this thread
I thought I had done better before, but really, my testing has always been limited by using my cable connection (300/30mbit, sometimes does 350 ingress) and not setting up something custom.

Curious I checked again, watching in top for sirq and idle %. I saw a peak of 250-260mbit with the 5ghz radio, but only 70-80% sirq, and 20-25% idle left. I remembered peaks of 270-280mbit or more. THEN, I remembered I had switched to 40mhz bandwidth. Switching to 80mhz got back up to th 270-280, AND I was hitting 95% and more with idle time hitting 0%.

I realised I had been having better luck lately in not seeing the every few days drop of the 2.4Ghz radio. Around the same time I also had changed to the Apr 3 snapshot, for the AQL/airtime fairness work for ath10k, so possibly newer firmware/drivers are in the mix as well.

I'm now wondering if there is some bug in there, that gets triggered when the system runs low/out of sirq or overall resources? This might explain odd observed behavior in other threads on this, where doing something or disabling the 5Ghz radio affects the 2.4Ghz one. Different branches of code and hardware, shouldn't affect each other, but maybe the ath9k branch can hang when things max out, and it's the 5Ghz branch that has the ability to max it? Or, the later FW/driver releases are better?

How do we pass this to developers in this area as an idea to check?

+1 on this, also happening to me. if there is anything i can provide to help troubleshoot or diagnose the issue, i'm happy to try and help.

Well, lets see... real quick, I'm using a snapshot, from June 4th... that would be a lot of newer stuff, probably the more important may be the ath9k/ath10k drivers and firmware. Been newer ones since then.
Curious what version of firmware are you running?

Settings that may help, and you probably should try first, is that I run 20mhz on 2.4ghz radio, and 40mhz on 5ghz as mentioned above, to keep the C7 cpu from maxing out. I also run with the KRACK protection turned off, legacy rates disabled, and the beacon at 100 (that's stock) but the DTIM interval set to 1 (not stock). I also run at a lower that max power, and with isolate clients on.

Some of that is maybe just preference, some just a good idea, but maybe in there is something that helps, since I've had much better luck lately. It's maybe been a couple of weeks since my last instance of the 2.4 radio going unresponsive. Give those a shot, and see if that makes any difference with you.

Hey JonP, thanks for getting back to me. I had previously installed luci-app-statistics to keep an eye on what was going on, and was checking the graphs every few days. I really haven't seen any dramatic load spikes, in fact, the opposite. CPU wise, things have been calm.

As such, I just installed the current snapshot on my C7 v2 (OpenWrt SNAPSHOT r13920-1db3fb5842). Things are running fine for the moment, I'll keep an eye on it before tweaking settings. Current settings are 80mhz for 5ghz, 20mhz for 2.4, KRACK is off, DTIM is 2 (stock), allow legacy rates is off, isolate clients is off.

rrdtool of course is averaging CPU so maybe there are spikes that I'm missing -- I'm curious to leave it as-is with the snapshot and see if the situation is improved.

I'll report back if I find any problems. Always excited to be running updated firmware.


One thing to note -- I immediately noticed that upon switching to the Archer C7 v2 snapshot vs 19.07.3 that I'm getting a higher rx/tx rate w/ my 5ghz clients.

I switched to the non-CT driver and I haven't had any issues.

Yeah, with the luci-app-statistic graphing, it takes a sample every 30 seconds or so? Hard to see really short, bursty stuff like I get with the cable service when things are kinda overloaded. You definitely can see the long term 2.4ghz dropouts, data rate and clients drop to 0...

If I want to look at more immediate loading, I open a SSH window and log on, run top -d1, and watch the idle time primarily. When it gets to 0%, you are pretty much saturated. Took me a while before I realized that you can have less than 100% CPU, but be saturated by IRQ's and such, that don't show up elsewhere. That's how I noticed the odd thing when on the 5ghz radio, at 80mhz, on some very heavy loading like a DSL Speedtest... my C7 ran out of idle! Still don't know if that should be happening, this is even a dumb AP, so no routing tasks to hold up, should be even less loaded than a "normal" C7. I had suspicions that that might have been a part of the 2.4 dropout, or trigger it, but others have said it's happened with the 5ghz radio off. Don't know.

You're tempting me to try the recent snapshot, and their newer driver versions than my June 4th snapshot has. Fastrer than stock, eh? What kinds of speeds are you seeing? I've rarely seen 280mbit with 80mhz bandwidth... but I've always thought that was mainly because I have a 300mbit connection.

this has been discussed in many threads. Bascially 2.4 on C7 is buggy and has been so since 18.6. It will fail under high load. There this hearsay that you can make it better by switching unrelated 5GHz drivers (2.4 and 5 are two completely different radios with different drivers) but at least in my testing it did not help. I tried CT/non-CT/backdated etc. 5GHz drivers and 2.4 still failed eventually.

Unless there is a coverage issue, old devices or low bandwidth, just switch off 2.4 and use 5 GHz. It is better in all aspects except range anyway.

And yes, C7 760MHz single core CPU is just about enough to run 5 GHz at full tilt (80MHz, WPA2). It will be 100% utilized if 5GHz is loaded to max even as AP. This is not a bug, there is just not enough oomph. You can bring it to 95% if you overclock the router. This again does not seem to affect 2.4 stability. 2.4 will fold even with 5GHz disabled, drivers removed and CPU % left.

Thank you for sharing your experience.

I'm sharing my experience, that with a later than last stable version, and some settings changes, I have gone from having this problem every 2-3 days, to coming up on 4 weeks now without noticing it return.

Had someone downloading several full games on some kind of free offer, 10s of GB's over >4hrs maxing out the 2.4ghz, till I told him the 5ghz might be faster... no problems.

If you want to get rid of your buggy C7's... I could use one or two, as AP extensions...