TP-Link Archer C6U v1 - problem with wireless connection to mobile router Huawei

Hi everyone!

I'm trying to connect TP-Link Archer C6U v1 (EU) on OpenWrt 22.03.0 r19685-512e76967f via 2.4Ghz to a HUAWEI E5576-320 mobile router that distributes the Internet. And on 5Ghz, I want TP-Link to work as an access point and distribute the Internet (I need this in order for traffic to go through VPN, because WireGuard client is configured on TP-Link).

In the web interface, in the Network -> Wireless tab, i see that TP-Link is trying to connect to Huawei, but the connection is being reset.
How to understand why and fix it?
Thanks in advance!

Config wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'tpl5'
        option encryption 'psk2'
        option key '*****'

config wifi-iface 'wifinet3'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'HUAWEI-6E70'
        option encryption 'psk2'
        option key '*****'
        option disabled '1'

Config network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd27:a09d:a12d::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '*****'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config interface 'wwan'
        option proto 'dhcp'