TP-Link Archer C60 v2 only power light and nothing else

Let me apologize for trying out stuffs without proper knowledge.
I was facing upload speed issue with my archer c6 router and decided to try out openwrt. Installed successfully but had to revert back to he original firmware for some reason. Tried TFTP64 with steps but there was no send/receive between the router and the device. So I restarted the router and openwrt opened again. Finally came to know about firmware strip. Stripped the original firmware watching YouTube video and some documentation, flashed the stripped firmware from openwrt firmware backup/upgrade menu. After a while only the power light was lit and nothing else happened for more than 30 mins. So I unplugged the cable and restarted the router.
Now, there is no connection between the router and device through lan cable. Not recognized. Only the power light is lit and nothing else happens.
Please help me out. I severely messed up.

Can you still initiate the TFTP recovery, like before ?

If not, you'll need a serial cable to investigate why it's failing, but there's a risk you've bricked it.

I don't know why but the router is not recognized by the tftp server.
I could not initiate tftp server before and still cannot

By the way, if I need to connect the router via serial cable, will cp2102 work fine?

Failing tftp transfers are usually caused by firewalls.

Yes, cp2102 usually works just fine.

Yes I have used this exact command to strip the factory firmware and flashed through openwrt
Thank you so much for your support. Really appreciate everyone in this community. :heart:

You are welcome
As I know the Image file ( ArcherC60v2_un-up-ver2-0-0-P1[20161206-rel60287].bin) doesn't contain uboot and there is no need to strip the original image

You made mistakes
1.You Stripped the original firmware
2. Uploaded stripped FW directly via Web
You should have renamed the original FW to tp_recovery.bin then Upload it to your router Via TFTP

Watch this video from Youtube

You can mute audio cuase this guy from the video talks too much

I tried to upload your file via tftpd64 again but nothing pops up after "holding the reset button, power up, release". Just blank.
Here is what I did
Changed the Ethernet adapter ip to
Set the same ip in tftpd browsed the correct folder containing your file. Didn't work
Even tried to use tftp cluent, set the host to, port to both 22 and 69. Located the file and pressed PUT after plugging the router on holding reset button. Didn't work either. But this time got something in the log viewer.
Here it is

Connection received from on port 52045 [20/06 05:56:14.478]
Write request for file <tp_recovery.bin>. Mode octet [20/06 05:56:14.478]
OACK: <tsize=7897266,> [20/06 05:56:14.494]
Using local port 52046 [20/06 05:56:14.494]
<tp_recovery.bin>: rcvd 15425 blks, 7897266 bytes in 2 s. 0 blk resent [20/06 05:56:16.213]

Don't use that Stripped FW that I uploaded before
Just Download the Original firmware from TP-Link website ,rename FW to tp_recovery.bin
then upload it via TFTP
As I said before "No needed to use stripped firmware for this router"

The firmware was uploaded via TFTP to your router but not the right one
That's why you got nothing

1 Like

No luck. Tried the original firmware with the original rename and also tried renaming as "tp_recovery.bin" on both port 22 and 69
A popup came and have got log info


15681 blocks transferred in 2 seconds 0 block retransmittedMD5: 11f90b03926ef452f97b19c2e0dc93d9


Connection received from on port 65366 [20/06 06:38:13.294]
Write request for file <ArcherC60v2_us-up-ver2-0-0-P1[20161206-rel65407].bin>. Mode octet [20/06 06:38:13.294]
OACK: <tsize=8028360,> [20/06 06:38:13.294]
Using local port 65367 [20/06 06:38:13.294]
<ArcherC60v2_us-up-ver2-0-0-P1[20161206-rel65407].bin>: rcvd 15681 blks, 8028360 bytes in 2 s. 0 blk resent [20/06 06:38:15.174]

Have you watched the video on YouTube that I sent to you ?

Yes, followed him step by step.
Actually I've tried his exact steps before bricking my router. His steps did not work for me for some reason. Still not working.

I had the same problem last year and when I upload Openwrt FW via TFTP nothing happened and search a bit
By changing Port on TFTP I could bring it back
for uploading FW via TFTP You MUST rename FW to ' tp_recovery.bin '
Somewhere,somehow you are doing something wrong
Your router is EU or US Version?!

Us version

As I know there isn't US version for Archer C60 on TP-link website
Maybe US version is different than the EU, that's why you can not bring it back

Other than the renamed firmware that you gave me, I've been trying to use flash the us version of the original firmware

Let me know if something happens


i have same problem please provide me full dump file.