TP-Link archer C6 v2 EU 2.4 ghz not working

Hello,

I have flashed OpenWrt 19.07.7 r11306-c4a6851c72 on my TP-Link Archer C6 v2 EU and configured it as a dump AP (no DHCP, DNS & Firewall).
5Ghz works fine but 2.4 Ghz doesn't. When I activate the radio, I see the SSID & can connect to it but after 1-2 minutes it disappears & device is disconnected.

Here are my current wifi settings:

config wifi-iface 'default_radio1'
option device 'radio1'
option mode 'ap'
option network 'lan'
option key 'PASSWORD'
option encryption 'psk2'
option ssid 'WIRELESS SSID'
option disassoc_low_ack '0'

I've tried to activate following options to no avail:

  • Frequency legacy (instead of 'N')
  • Manually choose a differen channel
  • Set the country code
  • Disable WMM mode
  • Disable 'Allow legacy 802.11b rates'

What else could I possibly set to make my 2.4ghz working?

Check the wireless drivers. The C6's QCA9563/9886 should be using the non CT version. I think you should be using:

ath10k-firmware-qca988x
kmod-ath10k

Although apparently the drivers never really worked that well for 2.4Ghz so YMMV.

There are apparently work arounds for similar problems on the C7 v2 (QCA9558/9880) perhaps you could try?

The C6 may be best used without 2.4Ghz which is how I use QCA9563/9886-7 based devices.

https://community.tp-link.com/en/home/forum/topic/221276

Thanks for the advice. How can I check which drivers are in use?
I've found these ath packages installed:

It seems it is the CT version indeed. How can I switch to non-CT? Or is a downgrade more easy to execute?

Strangely, I've got an C7 v2 which has been working flawlessly for several months now using the same OpenWrt version (19.07)

Before you do any of this do a backup just in case: LuCI->system->backup

By deleting the ath10k-ct drivers under the "installed" menu, and then installing the non CT ath10k drivers from the "available" menu.

  1. LuCI->system->software->update lists->installed->ath10k-firmware-qca9888-ct->remove->dismiss

  2. filter->ath10k-firmware-qca9888->install->dismiss

  3. Do the same thing with kmod-ath10k-ct, and install the non CT version.

Sry for the late reply. I've finally found some time to test this.
I've done as per your instructions and now 2.4Ghz is working as it should.

Thanks for your help!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.