TP-Link Archer C6 V2 bricked? unidentified network, only power led

Hello.

I probably make mistake with force flash official firmware thru OWRT Luci GUI v19.07.1.

Now under Windows I get unidentified network (wire) without IP assigned and on router only Power LED shining (not blink even once) and reset button is unresponsive.
Connected with wired cable but only Power LED shining. If I try powering router off/on, all leds blinks once and then only power led stable shining without blinking.
TFPD cant access router without IP

pls help, thx

Definitely, not probably. You need to TFTP the official firmware to unbrick the router (since the partition layout is most likely toast) and reinstall OpenWrt.

1 Like

thanks for answer ... but HOW connect with TFPD if no communication between router and PC? "unidentified network" means no IP assignet, and whats more only power led stable shining without blink

I know the drill... static IP 192.168.0.66 and TFPD64, rename recovery file in root folder etc. hold reset and power on, but file not uploading to router

Did you read the link posted by @rsalvaterra ?

Screenshot from 2020-03-03 15-23-17

yes, this is standard TFTP recovery I did it successfully before with another C6, but never with "unidentified network" and only one Led

sadly nothing is uploaded (downloaded by router)

Without JTAG, if the bootloader itself is damaged, there's nothing else you can do, aside from desoldering the SPI chip and using an external programmer to reflash it (and that's assuming the original firmware image also contains the bootloader).

1 Like

so ... in the IT service they fixed this router in five minutes with TFTP and official firmware ...!
no need for special treatment, no serial, but classic TFTP

I dont know what I do wrong ... because some connection between network card and router exists according to Wireshark packets. But on my PC Win10x64 admin (def. Firewall) I have zero communication / LOG with TFTP.

Official firmware means you recovered the device to use the TP-Link firmware? This is what I am trying to achieve without any luck so far. Any pointers on what to do would be super appreciated.

yes, but with 2018 firmware... I managed it too once before, but not this time... whats more 2018 firmware cannot be found so easily anymore
https://forum.openwrt.org/t/19-07-build-for-archer-c6-v2/41118/53

@Zambee just in case, had similar issues, but found the solution. You need a switch to connect your PC and the router: you can't just plug the PC to the router you try to tftp to. It is also useful to have wireshark monitoring your ethernet card to see wtf is going on there. Last but not least, to make tftp on router work, you start the router with the reset button pressed, and after a couple of seconds (~5s ?) you release the reset, and see the wireshark packets flowing. For me, PC was 192.168.0.66 and router was 192.168.0.86.
Hth.

did you manage to solve?

that time I tested everything and there was unidentified problem in my PC which blocks force uploading firmware to router... ISP provider technician proceeded in the same way without problem

tip for those who are desperate. My technician managed to upload the bin using the FileZilla program

I know this thread is already dead, but for those of you that (like me) may come here looking for answers, here is what I did to get it to work.
So I did the same mistake as @Zambee and force-flashed a firmware through Luci that got my router "bricked" with nothing but the power led on and completely unresponsive.
I tried (as @rsalvaterra mentioned) to follow the openwrt official procedures but at first I wasn't able to get any reply from the router, or in fact have anything logged on the tftp server logs.
So about a day's search in, and looking through several websites, here is what I was doing wrong and how I was able to bring it back to life:

1- make sure the image you're using for recovery fits your router memory (ideally download it from the official openwrt website - search for your router module) For the Archer c6 v2 use this one: https://openwrt.org/toh/tp-link/archer_c6_v2
2- In case of the Archer C6 check which version you have (EU,RU/US) and download the correct one. Rename it to "ArcherC6v2_tp_recovery.bin" (without quotes of course)
3- Install tftpd64 or tftpd32 (depending on whether you have a 32 or 64bit system), if you're not sure go with 32. Configure it to the folder where you saved the ArcherC6v2_tp_recovery.bin to (ideally create a folder just for this purpose and store only this file there).
4- THIS IS IMPORTANT: create an inbound rule in your firewall to allow tftpd traffic, or disable the firewall comlpetely (temporarily, don't forget to put it back up after it's done)
5- Get a 10/100 switch (not gigabit, it has to be 10/100)
6- Connect one ethernet cable from the port1 switch to the port1 on Archer C6 (DO NOT USE the Archer c6 WAN port), and another cable from the port2 switch to your PC Lan adapter.
7- THIS IS VERY IMPORTANT: go into the PC LAN adapter advanced settings and set the speed&rate to 100Mbps Full Duplex
Capture
8- set your PC LAN adapter IP address to static (IP=192.168.0.1/Subnet:255.255.255.0)and all other fields you can leave blank
9- boot your Archer router into recovery mode by pressing down on the reset button before turning it on (keep the reset button pressed for 10seconds after turning on the power)

NOTE: for me the way it worked better was using an old laptop I had lying around, did a fresh win7 install and disabled the firewall completely. After that I ran the above mentioned steps and it worked

Hi, I follow your steps but I don't know beacuse TFTP flash doesn't work; I tried 4 OS (Win11, Win10, Win7, Ubuntu), 2 software (tftp64 and SolarWinds TFTP Server); no logs from WireShark. I tried other tutorials, but nothing works. The archer still turn on and only power LED on (solid green), anyone have any other metod?

Download the stock firmware.

Download TFTP64.

Rename the downloaded firmware file to ArcherC6v2_tp_recovery.bin, and place it in the same folder as TFTPD64.

Open your network settings in Windows, and select the wired adapter (don't try this on a wireless connection).

Right-click and select Properties.

Select Internet Protocol Version 4 (TCP/IPv4) and click on the Properties button.

In the General tab, select the radio button for Use the Following IP Address.

Enter 192.168.0.66 for the IP address.

Should default to 255.255.255.0 for the Subnet Mask.

Turn the router off.

Make sure nothing else is connected to the router, it should be just the router and your computer.

Open TFTPD64. You may be asked to allow it through the firewall. Select Public.

Go to Settings > Global, and uncheck everything except TFTP Server.

Go to Settings > TFTP. Select None for TFTP security. Uncheck Option negotiation, and enter 192.168.0.66 in the Bind to this IP address drop down.

Go back to the main window, and make sure the Current Directory dropdown is showing the path to the TFTPD64 folder, which should also contain your recovery firmware file ArcherC6v2_tp_recovery.bin

The IP address 192.168.0.66 should be displayed in the Server Interface dropdown. If not, select it.

Go to the router and press the power button and the reset button at the same time.

Release the power button...but continue to hold the reset button for about 4 or 5 seconds, then release.

You should see a progress bar going across the TFTPD64 screen (although it should only take a very short time).

View the log. It should show 100% transferred.

Go back to your wired network adapter, and change the radio button back to Obtain an IP Address Automatically.

Try to access the router GUI. The stock firmware IP address is 192.168.0.1 and admin/admin for the User Id and Password.

If you can see that you have Internet access in the Network icon, but can't access the GUI, open a Command prompt and run ipconfig /release and then ipconfig /renew.

Try to access the GUI again.

Sadly I tried this several times without success, no progress bar and no logs. Thanks for your help.

One very important thing that you didn't mention was if you changed the speed settings to 100mbps. Jist wanted to make sure.... By default it's auto negotiate, and it won't work with that setting. Try 100mbps full duplex, if that doesn't work try half duplex. If none of these work try 10mpbs (half and then full). You can find these settings on the ethernet card driver settings.

I personally have never changed the speed setting in the NIC, and never had an issue.

A lot of issues stem from flashing firmware for the wrong region, firewall permissions, and not holding the reset button long enough before releasing.

But whatever works.

It depends on the NIC you're using. Probably tops at 100 full duplex, if it has gigabit capability it wouldn't (probably) work, but it really comes down to the way the driver negotiates the transfer mode. In my case it didn't work until I messed around with the speed/duplex settings.