TP-Link Archer C6-US: Install from GUI?

I have not been able to install OpenWrt on my TP-Link Archer C6-US router. These are the issues:

  1. The TP-Link "recovery mode" does not seem to work at all. Pushing the reset followed by the power switch then waiting for the WPS light caused nothing on the TFTP server (blank, really). It was running on Windows 10 with the firewall and antivirus off. Using a switch or another switch or even another computer changed nothing. And I probably tried other things that I can't remember.

  2. I could not figure out if OpenWrt for the EU version of the router will work with the US version. I did not find a specific build for OpenWrt for the US version.

  • My question is: How do you upload something using the original TP-Link GUI for further upload purposes only? Is this simple to compile? Additionally: will the EU version brick the router?

Are you following these instructions?;a=commit;h=9b90dc05f58c619962e69e36d275b6ea56893496


Hi tmomas, thank you for the reply. Your answer fixed the problem.

It turns out that I was trying to flash the wrong image, the correct one is openwrt-ath79-generic-tplink_archer-c6-v2-us-squashfs-factory.bin (emphasis on "US") which works directly from the TP-Link GUI without any issues. After that all of the normal procedures for OpenWrt seem to work (for example installing the Luci GUI using ssh).

Issue solved!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.