TP-LINK ARCHER C6 not working wifi

Hi all,

after having installed the openwrt firmware 21.02.0, I could not manage to have the wireless working on any of the two channels. Strange enough, it wirked fine for the first hour or so, now even with the radio enabled It does not generate any wifi net. It is just as if it does not have the wifi.
I tried to downgrade the firmware going to the previous version, to reinstall the latest, to reset everything but nothing worked.
I cannot get back to the original firmware, that at least had the wifi working, so it is close to go to the bin ...
My version is v 2.0 EU.

Thanks a lot for any support into this matter.

Perhaps you need to set the country code in Device Configuration > Advanced Settings


uci set'XX'
uci set'XX'
uci commit wireless
wifi reload

where XX is whatever is appropriate for your country

Thanks for your reply jaromanda.
Do you mean the Router country code or the code of the country I am using the router in, since I bought it in Europe and I am now using it in the Middle East ?

The country you're in.

1 Like

Thank you very much frollic.
I now have 5ghz band working ... but 2.4 still not though