TP-Link Archer C50 v3 - Stripping U-Boot from OEM Firmware

After successfully loading 18.06.1 and testing wifi speeds, the 2.4Ghz channel isn't performing as i'd hope for (5Ghz is pretty fast). I understand that the OEM firmware needs to have the UBoot portion removed before flashing. I've tried it with HxD hex editor and remove the first 0x200 or 512 bytes of data and an unsuccessful in booting after flashing w/ TFTP method.

Does anyone have a prestripped OEM firmware for Archer C50 v3?

Link to lastest Archer C50 v3 firmware for Canada.

If you load it from tftp you should leave the file as is.
That could seriously brick your device and is a method for returning to stock firmware from OpenWRT afaik.

Did you put your device into download mode ?

Yes, i have used the TFTP method to restore the OEM firmware. Once it completes, i give it about 5 minutes and power cycle the router. When it powers back on, all lights are flashing on the router.
I use the TFTP method again to upload OpenWRT.

As per this links "", it describes the need to edit the OEM firmware in order to revert from OpenWRT to OEM firmware.

Here ya go mate! link is valid for 30 days.


Good luck!

Someone Have TPLINk C50 V3.0 Stripped recovery file?

Check Your Inbox

Thank @David.S.Mckellen. I tried installing this firmware in my c60 v3, but in vain. This doesn't seem to work either & neither does the original firmware from TPL website. I guess we have no way to go back to stock firmware from Openwrt on TPL C60 v3.

Can anybody upload this stock firmware to flash back again?

Thank you!